CVE-2015-5986: An incorrect boundary check can trigger a REQUIRE assertion failure in openpgpkey_61.c

Michael McNally mcnally at
Wed Sep 2 19:55:39 UTC 2015

CVE:                       CVE-2015-5986
Document Version:          2.0
Posting date:              02 September 2015
Program Impacted:          BIND
Versions affected:         9.9.7 -> 9.9.7-P2, 9.10.2 -> 9.10.2-P3.
Severity:                  Critical
Exploitable:               Remotely


   An incorrect boundary check in openpgpkey_61.c can cause named
   to terminate due to a REQUIRE assertion failure.  This defect
   can be deliberately exploited by an attacker who can provide a
   maliciously constructed response in answer to a query.


   A server which encounters this error will terminate due to a
   REQUIRE assertion failure, resulting in denial of service to

   Recursive servers are at greatest risk from this defect but some
   circumstances may exist in which the attack can be successfully
   exploited against an authoritative server.  Servers should be
   upgraded to a fixed version.

CVSS Score:                7.1
CVSS Vector:               (AV:N/AC:M/Au:N/C:N/I:N/A:C)

   For more information on the Common Vulnerability Scoring System
   and to obtain your specific environmental score please visit:


   No workarounds are known to exist.

Active exploits:

   None known.


   Upgrade to the patched release most closely related to your
   current version of BIND. These can all be downloaded from

   +  BIND 9 version 9.9.7-P3
   +  BIND 9 version 9.10.2-P4

   BIND development releases scheduled to be published at the same
   time as the public disclosure of this vulnerability will also
   contain the fix for this security issue.

   +  BIND 9 version 9.9.8rc1
   +  BIND 9 version 9.10.3rc1

Document Revision History:

   1.0 Advance Notification 19 August, 2015
   2.0 Public Disclosure  2 September, 2015

Related Documents:

   See our BIND9 Security Vulnerability Matrix at for a complete listing of
   Security Vulnerabilities and versions affected.

If you'd like more information on ISC Subscription Support and
Advance Security Notifications, please visit

Do you still have questions?  Questions regarding this advisory
should go to security-officer at  To report a new issue,
please encrypt your message using security-officer at's PGP
key which can be found here:  If

you are unable to use encrypted email, you may also report new
issues at:


   ISC patches only currently supported versions. When possible we
   indicate EOL versions affected.  (For current information on
   which versions are actively supported, please see

ISC Security Vulnerability Disclosure Policy: 

   Details of our current security advisory policy and practice can
   be found here:

This Knowledge Base article is
the complete and official security advisory document.

Legal Disclaimer:

   Internet Systems Consortium (ISC) is providing this notice on
   an "AS IS" basis. No warranty or guarantee of any kind is expressed
   in this notice and none should be implied. ISC expressly excludes
   and disclaims any warranties regarding this notice or materials
   referred to in this notice, including, without limitation, any
   implied warranty of merchantability, fitness for a particular
   purpose, absence of hidden defects, or of non-infringement. Your
   use or reliance on this notice or materials referred to in this
   notice is at your own risk. ISC may change this notice at any
   time.  A stand-alone copy or paraphrase of the text of this
   document that omits the document URL is an uncontrolled copy.
   Uncontrolled copies may lack important information, be out of
   date, or contain factual errors.

(c) 2001-2015 Internet Systems Consortium

More information about the bind-announce mailing list