(no subject)

Amy Briggs abriggs at scnc.ds.k12.mi.us
Thu Nov 11 21:48:12 UTC 1999

I've got DNS 8.2.1 up and running on a Solaris 2.6 box.  I am now trying
to move my mail over to this box.  I keep getting the following error in
my log file:  

Nov 11 15:54:30 echo sendmail[4398]: PAA04396: SYSERR(userid):
mailhost.xxx.com. config error: mail loops back to me (MX problem?)

I have my MX record pointing to my new mail server (which is also the
DNSserver) and have tried adding a CNAME for mailhost pointing to my new
mailserver name:

mailhost	IN	CNAME	echo.xxx.com

With this I get the error so I commented it out and added a second A

mailhost	IN	A ; no this is not the real ip.

And I still get the error, it goes away if I leave out the mailhost A and
CNAME record but then I get the following when a new user tries to request
the Pine doc:

Subject: Returned mail: Host unknown (Name server:
mailhost.xxx.com: host not found)

So, it needs a record for mailhost.  Does anyone know what I am doing
wrong?  My DNS MX records work fine when I point them to the old mail
server which is on a different box for the MX record and a mailhost CNAME
pointing to the different box.  Can you not run DNS and mail on the same
box anymore?

Any quick help would be appreciated,


More information about the bind-users mailing list