Solved: Dig-yes, ping-unknown host

Torsten Behle behle at
Tue Nov 23 19:51:45 UTC 1999

I've got it. (some time ago, but my provider's news server is lame)

Some may remember a problem with bind 4.9.7 on
SuSE-Linux 2.2.10.
Was able to dig everey host. But ping/ftp/traceroute/... gave
"unknown host" with SOME hosts. All were CNAMEs.
Checked config, reinstalled, upgraded to bind8 (assuming
conflict between libs, corrupted files).
Nothing worked.
A friend pointed me to the nscd, for which I found a
bug-entry in the SuSE-Support-Database at

Here's a quote:
> There is a bug in the library ´´, specifically
> a buffer-overflow, when the appropriate routine is called
> with extremely long strings (ie. computers with long names
> (and aliases) with many IP addresses). The "nscd" daemon
> (Name Service Cache Daemon) forces this error, whereby
> the error described often occurs.

To get the error less often (meaning only with really extreme
long names or extreme many aliases), you can set
´enable-cache hosts´ from ´yes´ to ´no´
in /etc/nscd.conf, which is a new default in SuSE 6.2.

As a longterm solution I will of course have to update the lib.

Thanks to all for helping.
Torsten Behle
FCB/Wilkens Hamburg

More information about the bind-users mailing list