CACHE Question

Will Yardley william+dns at
Mon Oct 8 17:56:40 UTC 2001

Kris McElroy wrote:

> We are running 9.1.1 on Red Hat Linux 7.1 We use bind as our caching
> server and have for some time.  We have never had any problems with
> it.  A customer calls me and says he can't get to a particular
> website.  I try to ping it and it comes back unknown host.  I get on
> an NT workstation and ping it, nslookup, and still no luck.  I did a
> killall -HUP named and still no luck.  Then I restarted name with no
> luck.  The website is and this is the only
> one that is giving me any problems.

it seems to be working OK to me:
aura% dig @NS1.USLIVE.NET. any +norec +sh
aura% dig @NS2.USLIVE.NET. any +norec +sh

i can view the site in lynx as well, and recursive lookups seem to work

one thing that's kind of weird is that the nameservers don't seem to
have NS records for themselves;

aura% dig NS1.USLIVE.NET. @NS1.USLIVE.NET. ns

; <<>> DiG 9.2.0rc5 <<>> NS1.USLIVE.NET. @NS1.USLIVE.NET. ns
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8315
;; flags: qr aa rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;                        IN      NS

;; AUTHORITY SECTION:             86400   IN      SOA 2001090511 21600 10800 604800 43200

(and the same @ns2).

also two of the authoritative nameservers for '' are timing
out for me at the moment (ns3 and ns4) - if these aren't valid you
should remove them although that's neither here nor there for your
particluar question.

anyway a few other points.

1) upgrade, upgrade, upgrade.... bind 9.1.1 is old and there have been a
lot of bug-fixes since.  if you don't want to compile for source, there
are even some rpms of much later 9.1.x and 9.2.x releases.  i'd
suggest a 9.2 release candidate or 9.1.3 release.

2) don't HUP bind9 if possible - use rndc. you will need to setup rndc
if you haven't already.

3) some of the records have a really short TTL - which appears to be the
same as the minimum.  you might want to set an explicit TTL for each
record, or at least set a slightly longer TTL at the top of the zone

does anyone else see something wrong??


GPG Public Key:

More information about the bind-users mailing list