DNS lookup failures on .org domain

Mark_Andrews at isc.org Mark_Andrews at isc.org
Mon Feb 25 00:39:12 UTC 2002

> > I've got Bind 9.1.0 set up on a machine on my home network. It serves a 
> > small domain to keep track of local machines ( <10 of them) and caches 
> > internet name queries.
> > 
> > I have an ADSL line, so the name server isn't strictly necessary, but 
> > I've got it as a learning excercise as well as to reduce the external 
> > line load.
> > 
> > The problem I have is that some times Bind seems to lose certain 
> > domains, commonly the .org ones (off the top of my head I can't remember 
> > any others misbehaving). It will resolve them quite happily for a while 
> > and then just stop and return lookup errors. Most the time it sorts 
> > itself out a while later, otherwise restarting Bind normally fixes the 
> > problem for a while.
> > 
> > My guess was that the .org servers are responding slightly too slowly, 
> > Bind was timing out and then caching the error until such time as it 
> > tried resolving the domain again and succeeded.
> The name servers that serve org are the same set of name servers that
> serve com and net.  If they started responding slowly, it would affect
> com and net just as much as org.
> Have you tried turning on debugging when the problem occurs, or
> maybe tracing the DNS activity with tcpdump or ethereal?
> cricket
> Men & Mice
> DNS Software, Training and Consulting
> www.menandmice.com
> Attend our next DNS and BIND class!  See
> http://www.menandmice.com/8000/8000_dns_training.html
> for the schedule and to register for upcoming classes

	Also BIND 9.1.0 is well past its "use by" date.  I would suggest

Mark Andrews, Internet Software Consortium
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: Mark.Andrews at isc.org

More information about the bind-users mailing list