Strange subdomain problem in BIND

dbotham at dbotham at
Tue Jun 18 13:29:40 UTC 2002

Wow, it is amazing how many people have been able to register the domain
"".  Posting the real domain name on this list will almost
always provide you with better and more accurate responses to your
questions.  Of course, everything you get for suggestions are guesses
without a real domain name...

My vote is that negetive caching is the problem, as Kevin Darcy has

You may also want to tail -f your syslog file and grep it for the domain
name in question while you are reloading the name server.  If the zone is
taking errors, you will see them there (by default on most systems...)



|         |           thelucas at |
|         |           (Lucas)          |
|         |           Sent by:         |
|         |           bind-users-bounce|
|         |          |
|         |                            |
|         |                            |
|         |           06/17/2002 03:49 |
|         |           PM               |
|         |                            |
  |                                                                                                                              |
  |       To:       comp-protocols-dns-bind at                                                                              |
  |       cc:                                                                                                                    |
  |       Subject:  Strange subdomain problem in BIND                                                                            |


i would really appreciate your help on this issue, since I wasn't able
to find anything about this. So, this is the scenario:

My server ( is set up as primary DNS Server for Everything seemed to work okay, until i tried to
create a subdomain, let's say I added a record into
the zone file,restarted the server .... and nothing happens.  Pinging
the subdomain from outside results in "host unknown". I tried it with
another domain, it works there! Could please figure out what could be
the problem?

; Zone file for

@       IN      SOA (
                        2002060801      ; serial, todays date + todays
serial #
                        8H              ; refresh, seconds
                        2H              ; retry, seconds
                        4W              ; expire, seconds
                        1D )            ; minimum, seconds

          IN      NS   ; Inet Address of name
          IN      NS
          IN      A
mail      IN      A ; THIS DOESNT WORK (points
ns0       IN      A
www       IN      A

Adding ANY subdomain for this domain results in failure. Any ideas?
Your help is greatly appreciated. I'm quite lost in this DNS problem.
I'm running BIND 9.2.0

Best Regards,


More information about the bind-users mailing list