named appears to be "broken" -- (was: really whacky issues)

Edvard Tuinder listbind at
Mon Jan 19 00:20:12 UTC 2004

According to Mark:
> *This message was transferred with a trial version of CommuniGate(tm) Pro*
> I have, as I said before, enabled recursion via the options in 
> named.conf
> when I run nslookup, it responds with the authoritative nameservers for 
>, regardless of the domain name i request.  the "Name" 
> output is -- indicating to me that 
> is being appended to requests.
> Whenever i run whois the output is "whois: No 
> address associated with hostname".
> So, just for the hell of it, I tried setting my hostname to null ("" -- 
> empty quotes), even though it could possibly foul up other services.  
> The results were the same.
> Any help would be appreciated.

nslookup is the wrong tool to diagnose DNS. It does not use the right library
calls to be reliable.

In your case, the appending of your local domain name, comes from the fact
that nslookup uses your /etc/resolv.conf search path. And apparantely your
zone has a wildcard which causes any query with nslookup to match.

Try using dig for testing, or add a final . to your query (so query for instead of

It'll probably show you that dns resolution itself works correctly.
If it doesn't, post the real configuration and the addresses of the
nameservers so we can test it ourselves. Do not edit the configuration,
only omit any auth-keys for rndc and such.


More information about the bind-users mailing list