BIND only resolves hostname on the second attempt

Scott Haneda lists at
Thu Oct 28 19:32:58 UTC 2004

on 10/28/04 6:16 AM, Brian Kendig at brian at wrote:

> A couple of days ago, my DNS server started behaving oddly: the first
> time I try to visit a web site, my browser tells me the server
> couldn't be found; if I then go to the same URL a second time, it
> works.
> My server is Mac OS X 10.3.5 running BIND 9.2.2. My clients are all
> Macs, running the Safari web browser, but the problem comes up with
> almost anything that tries to resolve hostnames; the game Halo, for
> example, gives me a "host not found" error the first time I try to
> connect to a network game, but connects on the second attempt. Just
> about the only thing which works consistently on the first try is
> running 'host' from a command line (as in, 'host' never
> complains it can't find the site).
> I ran named at debugging level 2 and tried a query which failed, then
> I tried it at debugging level 3 and tried another failed query, and I
> posted the logs at '' (I won't
> copy them here, because the stuff logged by -d 3 is long). A few times
> in the second example when it can't find '', I see it
> append my domain '' to the end and try that; I assume
> this is Safari seeing if the hostname exists locally.
> Can anyone please help me figure out what's going wrong, and how to
> fix it? What have I misconfigured?

Join the group, I think you are now person number 4 to have this happen in
the past few days, if you search the men and mice archive for subject "
Problems resolving" you can find mine as well as others posts.
Scott Haneda                                Tel: 415.898.2602
<>                     Fax: 313.557.5052
<scott at>                          Novato, CA U.S.A.

More information about the bind-users mailing list