Bind9 + PPP problem

P.B. at
Sat Oct 9 18:30:11 UTC 2004


I've just set up my linux box as PPP DialUp Server and can connect and do
everything except resolve names. The Linux server is also running Bind for
several years now - without problems.

There are several interfaces in this server (eth, wlan, ppp0(~ISP) - and
when serving dialup clients, also ppp1). The installed DNS works properly
for ALL installed interfaces, EXCEPT for ppp1.

I've tried the following:

1) Iptables entries are the same for wlan (where DNS works). Also tried
dropping iptables: no change.
2) Checked connection by connecting by IP (instead of by name)
3) used tcpdump to see what's happening: DNS request coming in from
ppp-client, but no answer.
4) bind's logs: (turned everything on for debugging): Request from
ppp-client does not show up in the logs,
but all other requests do.
5) Changed named.conf to bind to interface ppp1's IP, too.
6) Setup pppd to give the ppp-client an external DNS: works properly - So
that's why I assume it's my DNS having problems. seems like Bind is simply not receiving any requests from this

More information about the bind-users mailing list