Problem with Brazilian DNS servers

Mike Mitchell Mike.Mitchell at
Wed Nov 9 20:49:36 UTC 2005

Has anyone noticed a problem with DNS servers in Brazil?
I have problems looking up hosts in the following domains:

I get spotty results when querying those domains.  For example,
clients with a 149.173.5.XX IP address can query the Brazilian
nameservers with either UDP or TCP, but clients with 149.173.6.XX
addresses can only use TCP.  Packet captures at the Internet router
shows queries going out but never see a UDP answer back.  Since the
TCP queries function properly I know it isn't a routing issue.  I've
tried 'dig' with a one-second timeout and a repeat count of 50, and
the UDP query never succeeds.  When I immediately try it again using
TCP the answer comes back in 130ms.  I am querying the Brazilian
nameservers directly, i.e. 'dig @ A'

I've tried the same queries at different points on the Internet and
at some places it works, but others it doesn't.  I've even seen a case
where UDP worked but TCP didn't work.

Mike Mitchell
SAS Institute Inc.
Mike.Mitchell at
(919) 531-6793

More information about the bind-users mailing list