'failed setting up socket' error with BIND9 on Solaris 2.5

Udo Zumdick uz at nic.dtag.de
Mon Nov 21 10:29:07 UTC 2005

Hi all,

I wonder if anyone has experience with BIND9 (9.2.5 or 9.3.1 in this case) on
a SunOS 5.5.1 (Solaris 2.5) Ultra-2 Box.

I tried to set up a BIND9 on this machine and everything seems to be ok,
compiling, installation, resolving - no problems.

But I did not manage to configure the BIND as a slave for several domains.
There is not one zonetransfer that did it successfully. Any  attempt of an
axfr from the slave  to the master fails with the following error:

 Nov 20 04:20:58 moebius named[5278]: transfer of 'xxxx.de/IN' from failed setting up socket: socket already bound

Although I tried out several versions of BIND 9 this error always comes up.
The socket is definitively NOT used by any other process than the named on
this machine. As masters there are several versions of BIND, from 4.9 through
8.x to 9.2.4 without any other behaviors. 

At this moment there is unfortunately no way to upgrade to newer solaris on
the described machine.

Are there any ideas out there ?

Any help would be appreciated.

Thanks in advance !


More information about the bind-users mailing list