Setup email for host response

Jeff Lightner jlightner at
Mon Apr 17 18:43:25 UTC 2006

OK I've been looking around and not having much luck.   
We have a scenario where we need to "page" cell phones by sending an
email from a monitoring host to the email address of the phone (the
phone number with "@domain.dom").   This worked fine for us on AT&T cell
phones but due to their purchase by Cingular we're moving to Cingular
phones which have a different domain.   

It appears this new domain is checking to see if the sender is a real
user (can be replied to) and if not it simply won't forward the message
to the cell phone.  This makes sense in eliminating spam.   

We had one system that was sending out emails that had no real address
at all.  By modifying our MS-Exchange servers and associating that bogus
address to a real one and associating an smtp record with the bogus one
there we were able to get the mail to work successfully to the cell

Now however we have a server running Nagios for monitoring.   Since this
server has an FQDN ( the email comes out as being
sent by nagios at is our main domain.   When
it sends an email it also is blocked even though we did similar to what
we had done for the bogus address of the other system in MS-Exchange.   

I suspected this didn't work because is not a bogus domain so
it was checking our domain for it and not finding it.  Accordingly after
some reading I attempted adding a new $ORIGIN line to the end of my zone file and adding an MX record there for
domain to make it a subdomain.   This didn't help.   Something else I
read made it seem as simple as adding an MX record instead of creating a
subdomain.   This I did so now my zone file for has:
                IN MX   10  ; Main Mail Server
atlema01   IN MX   20  ; Entry for Nagios paging

On checking at for an MX record for it
finds the one I created above.   However on doing an email test from
that same site it gives an NXDOMAIN response.   It seems I'm missing

FYI:  I did try sending with the -f flag sendmail (mail/mailx) but it
didn't help either presumably for the same security reasons.   

I'm continuing to research but thought I'd ask if anyone had already
gone through something similar and solved the issue.

Jeffrey C. Lightner
Unix Systems Administrator
DS Waters of America

More information about the bind-users mailing list