UDP packet loss

Pavel Urban urbanp at mlp.cz
Sat Jun 10 09:04:06 UTC 2006

JINMEI Tatuya / ???? wrote:
>>>>>> On Thu, 08 Jun 2006 16:01:18 +0200, 
>>>>>> Pavel Urban <urbanp at mlp.cz> said:
>> I've tried to find out the cause of some strange resolving problem we 
>> are experiencing. From time to time, our server seems to ignore some 
>> requests, while others are answered promptly. It seems to me that the 
>> problem is UDP packet loss.
>> Udp:
>>      948795842 packets received
>>      149802 packets to unknown port received.
>>      214635022 packet receive errors
>>      1003702082 packets sent
>> I've tried to increase system udp receive buffer 10x and then 100x with 
>> no noticable effect. Do I have to change something in Bind, too? Or am I 
>>   completely wrong?
>> RedHat Linux ES release 4, 2.6.9-34.ELsmp kernel, dual Opteron system 
>> with 6GB ram, no local zones, just resolver/cache. bind-9.3.2-2_EL4
> A quick question: did you enable threads?

As far as I know, RedHat's packages are compiled with threads enabled. 
This server is quite busy, about 4MBit of DNS traffic for hours...

Pavel Urban (pavel.urban at imaginet.cz)
IOL system disaster
Internet OnLine, owned by Cesky Telecom, a.s. (www.ct.cz)
    Vegetables should not operate electronic equipment.
           Computer Stupidities, http://rinkworks.com/stupid/

More information about the bind-users mailing list