DNS Zone delegation doesn't work

galvuz fabio.galvagni at gmail.com
Fri May 12 09:22:03 UTC 2006

Hello to everyone,

i'm a student of Informatic Engineering, i'm finishing my studying with
a stage in wich i have to implement a complete DNS system with also
To do this, i'm using Vmware 5.0.0, with 3 virtual machine (Gentoo
Linux 2006)  connected on the same virtual network I called Protagora,
Gorgias, Socrates.

on Protagora i put the main NameServer and i configured it in order to
have a ( private ) zone/domain: 'galvanet'. so, protagora ( ) is protagora.galvanet, and socrates is
socrates.galvanet, etc...

All worked fine, until i tried to delegate a new zone. I wanted a new
zone called 'sub', with gorgias as the authoritative nameserver for
that zone. I wrote the new sub-zone files on gorgias, I configurated
bind, and i added the delegation on protagora.
On gorgias, all works well. if i try to use gorgias as the name server,
he works fine. ( the sub-zone is good ). But the delegation doesn't
works. I used this at the zone file of protagora:

; delega
$ORIGIN         sub.galvanet.
                     IN              NS             gorgias
gorgias         IN              A     

I don't know how is the problem. All seems good. If someone wanna help
me, i will be pleased. Maybe i forgot something for zone delegation ( i
nedd to set something on named.conf? )

More information about the bind-users mailing list