not authoritative while zone transfer

Shaheen wael.shahin at
Mon Feb 5 08:11:02 UTC 2007

On Feb 5, 8:02 am, Barry Margolin <bar... at> wrote:
> In article <eq4jcb$6m... at>,
>  "Wael Shahin" <wael.sha... at> wrote:
> > Hello List,
> > I am trying to add a zone today abc.def
> > i added the zone on the primary server and tried to update the secondary
> > server but i got the error not authoritative after notify recieved,
> This usually means there was a syntax error in the zone file on the
> master server, which prevented it from loading the zone successfully.  
> Check the log on the master for errors.

I thought that would be the problem too and I have double checked the
zone file on the server and created a new zone for testing and it stil
gives the same error and MS DNS is still able to transfer successfully

here is the conf line
zone "" {type master; file ""; allow-query
{any;}; allow-transfer {;; };};

here is the zone file
; BIND db file for

$TTL 86400

@       IN      SOA  (
                              06020409   ; se = serial number
                              3h         ; ref = refresh
                              15m        ; ret = update retry
                              3w         ; ex = expiry
                              3h         ; min = minimum

                IN      NS
                IN      NS


;               IN      MX      10      mail.domain.tld.
;               IN      MX      20

;//////////////////////// A
Records ////////////////////////////////////

                IN      A
www             IN      A

;/////////////////////// CNAME
Records ////////////////////////////////

ftp               IN      CNAME
;               IN      CNAME   A.domain.tld.

and here is the log from /var/log/messages for ns1, the master
Feb  5 09:58:00 localhost named[24069]: zone loaded
serial 6020501
Feb  5 09:58:00 localhost named[24069]: zone sending
notifies (serial 6020501)

Feb  5 10:00:25 localhost named[24069]: client
transfer of '': AXFR started
Feb  5 10:00:25 localhost named[24069]: client
transfer of '': AXFR ended

but secondary bind DNS is still giving the same error

> Barry Margolin, bar... at
> Arlington, MA
> *** PLEASE post questions in newsgroups, not directly to me ***
> *** PLEASE don't copy me on replies, I'll read them in the group ***

More information about the bind-users mailing list