SOLVED: Bind 9.2.5 and IPv6 fails with client.c:1325: unexpected error: failed to get request's destination: failure

Roland Dirlewanger Roland.Dirlewanger at
Wed Jan 17 21:09:16 UTC 2007

> Roland Dirlewanger wrote :
>> I have a very strange problem with a Bind server version 9.2.5 on 
>> Fedora Core 3.
>> Named listen to one IPv4 address and any IPv6 address. The 
>> configuration has been running for many months. No changes where made 
>> recently to the configuration except for adding or removing slave zones.
>> The symptom is that the server does not answer request to the IPv6 
>> address + port UDP 53. It still answers requests to the UDP and TCP 
>> port 53 using IPv4 and to the TCP port  53 using IPv6. Using dig on 
>> the server, or on any server on the same LAN, leads to the following 
>> behavior :
>> - dig ns some.domain @IPv4-address : works fine
>> - dig +vc ns some.domain @IPv4-address : works fine
>> - dig +vc ns some.domain @IPv6-address: works fine
>> - dig ns some.domain @IPv6-address: works once or twice immediately 
>> after restarting named, fails afterwards
>> The logs show the following message :
>> Jan 16 23:34:25 named[32125]: failed to get request's destination: 
>> failure
>> Jan 16 23:34:27 named[32125]: client.c:1325: unexpected error:
Pascal Hambourg answered :
> I think I experienced a similar problem with BIND 9.2.4 on Debian 
> Sarge. It seems to be triggered when the IPv6 UDP socket receives an 
> IPv4 request, which can occur in the following conditions :
> - IPv6 sockets allow IPv4 communications (default on Linux),
> - and a UDP request is received on an IPv4 address for which named has 
> no listening UDP socket.
> The result is the IPv6 UDP socket receives the IPv4 request and hangs.
> Cf. for more 
> info. I also included a workaround based on changing the defaut 
> behaviour of accepting IPv4 communication on IPv6 sockets.
Thank you very much to Mark Andrews and Pascal Hambourg for their 
answers to my message. I tried the workaround suggested by Pascal 
Hambourg in the above article :

# echo 1 > /proc/sys/net/ipv6/bindv6only

(and add this flag to /etc/sysctl.conf to make the change permanent)

It seems that the problem has disappeared. At least, requests on IPv6 on 
UDP port 53 have been working for more than 12 hours.Before the change 
of the bindv6only flag, they just worked for a few seconds.

Thanks again for your help.


Roland Dirlewanger
CNRS - Délégation Aquitaine-Limousin
Esplanade des Arts et Métiers - BP 105

Téléphone:, Télécopie:

More information about the bind-users mailing list