When Domain Resolution just Stops one Day.

Martin McCormick martin at dc.cis.okstate.edu
Mon Jul 30 20:12:05 UTC 2007

	Imagine a domain called thisdomain.org. It is registered
and looks up properly in whois. Thisdomain.org has subdomains
such as remotesite.thisdomain.org where they have a DNS that
sends us a slave zone we keep on the thisdomain.org DNS.

	If you lookup somebody.remotesite.thisdomain.org on our
master DNS, resolution is no problem. If you lookup the same
address on a slave DNS on your network that slaves the
thisdomain.org zone but not the remotesite.thisdomain.org zone,
it may still work fine for literally years. Then, one day, the
phone rings out of the blue and clients using that slave DNS
suddenly can not resolve remotesite.thisdomain.org. If you start
slaving that zone also on the slave DNS, everything is okay

	We have a situation today in which a domain that is a
subdomain of ours has always resolved from slave DNS's on our
campus but suddenly stopped last Friday after at least 4 years
with no incident.

	We also had this happen on one other occasion to a
different subdomain of ours. It had worked on our remote
campuses for a couple of years and then just quit one day.

	In all cases, I fixed it by bringing the slave zone from
the subdomain to the slave DNS's that had stopped resolving.

	Any ideas as to why it works so long without that extra
subzone? I either need to always bring subzone slaves to any
slave DNS's or I am doing something else wrong in the SOA which
eventually leaves lookups hanging with nowhere to go.

	My thanks.

Martin McCormick WB5AGZ  Stillwater, OK 
Systems Engineer
OSU Information Technology Department Network Operations Group

More information about the bind-users mailing list