Building bind-9.4.1-P1 on sco

Evan Hunt Evan_Hunt at
Wed Sep 5 18:32:01 UTC 2007

Okay, thanks; you're running OpenServer 5.0.6.  Do you know if all the
release supplements have been applied?  If you run "ls /opt/K/SCO/Unix"
you should see "rs506a.Unix5." and a few other directories.

I've built BIND 9 on that platform.  I never used --disable-shared, but I
don't know why that would make a difference.

I've just tried it now (note that --enable-static isn't needed, as it's on
by default):

        233%> setenv CC gcc
        234%> ./configure --disable-threads --disable-ipv6 --disable-shared
        235%> make
        236%> cd bin/dig
        237%> ./nslookup

        Non-authoritative answer:

Seems to be working okay.

> Sorry for the double post I was get gcc version when I bumped the send.
> I am using gcc (version 2.95.2 19991024 (release)).

Check your config.log to make sure that's what your build used.  You do
have an SCO development system installed, so it may have tried using cc,
unless you specifically set CC=gcc in your configure environment.

> I have also been looking at the socket libraries on this system.
> libsocket.a -> /var/opt/K/SCO/tcpdev/2.1.0Eb/usr/lib/libsocket.a
> -> /opt/K/SCO/Unix/5.0.6Ga/usr/lib/
> -> /opt/K/SCO/Unix/5.0.6Ga/usr/lib/
> I am not sure if those are the libs I should be using, but those are in
> /usr/lib. We link other network software on this system and everything works
> fine with this setup.

Yeah, those are the right ones.


More information about the bind-users mailing list