RFC2317-style delegation, nothing beyond CNAME

eric.benoit at gmail.com eric.benoit at gmail.com
Sun Jun 15 22:24:02 UTC 2008

Hey all,

I'm trying to figure out what has recently gone wrong with my reverse
DNS. I've been at the receiving end of RFC2317-style delegation for a
number of years now, and up until recently everything has worked

The problem seems to be in that the majority of the time, I'm only
getting the CNAME response, and that's it. Other times I get a "has no
PTR record" response. These results seem to be consistent from around
the globe.


$ host is an alias for 130.128/

(and it stops there)

Note that it does seem to work eventually and sporadically, and this
is what I expect:

$ host is an alias for 130.128/
130.128/ domain name pointer

Here's what dig says (with some parts omitted for brevity):

$ dig -x @ns1.igs.net +trace
(skipped.. usual header, root servers, arin, etc)

175.11.66.in-addr.arpa. 86400   IN      NS      dci.doncaster.on.ca.
175.11.66.in-addr.arpa. 86400   IN      NS      ns.istop.com.
;; Received 103 bytes from in 62 ms 86400 IN    CNAME
;; Received 91 bytes from in 50 ms

.. and stops there. I don't even see queries against my DNS server
(based on its logs).

I can proceed manually, though:

$ host -t NS 128/
128/ name server ns.oddity.ca.

$ host -t PTR 130.128/ ns.oddity.ca
130.128/ domain name pointer

The relevant part of named.conf is pretty basic:

zone "128/" {
        type master;
        file "/etc/namedb/db.";

and the zone itself:

$TTL 2h
@       IN      SOA     ns.oddity.ca. dnsadm.oddity.ca. (
                        2008061502 2h 1h 2w 1h
        IN      NS      ns.oddity.ca.

128     IN      PTR     quandary.oddity.ca.
129     IN      PTR     grumpy.nanuq.ca.
130     IN      PTR     paradise.ecks.ca.
131     IN      PTR     paradise.ecks.ca.

Any ideas why it seems to fail where it does? At first I suspected it
was in part due to the update to BIND 9.3.5 (from 9.3.4-P1) as part of
FreeBSD 6.3-STABLE, but the last time reverse seemed to have worked
was just prior to that update. A temporary downgrade didn't seem to
provide any relief.

BTW, if anyone familiar with this (former) ISP is suggesting I switch
as of yesterday, I'm certainly considering it now.


More information about the bind-users mailing list