Bind Patch for Solaris 10

Ray Van Dolson rvandolson at
Wed Feb 18 03:34:13 UTC 2009

On Thu, Feb 12, 2009 at 04:01:56AM -0800, Worrell, James J Mr CIV US DISA GS4T1 wrote:
> Thanks Ray!  Any information would be greatly appreciated.

Applied the patch but ran into one "gotcha".  The server wasn't
starting up properly after applyign the patch.  I tried running the
binary in the foreground and turns out it was complaining about not
being able to find /dev/poll in the chroot environment.

I ran:

  # cd /var/named/dev
  # mknod poll c 138 0
  # chmod 666 poll

And everything worked fine.  I'm not sure if Sun built things
differently or there is a new requirement on this /dev/poll file.
Regardless all seems to be working OK now.


> -----Original Message-----
> From: bind-users-bounces at
> [mailto:bind-users-bounces at] On Behalf Of Ray Van Dolson
> Sent: Wednesday, February 11, 2009 14:35
> To: bind-users at
> Subject: Re: Bind Patch for Solaris 10
> On Wed, Feb 11, 2009 at 12:30:19PM -0800, Worrell, James J Mr CIV US
> DISA GS4T1 wrote:
> > 
> > Greeting!
> > 
> > I am trying to load bind patch 119783-10 on a Solaris 10 system
> running
> > DNS 9.35-p2 and ran into several problems.  I suspect that the root
> > cause is due to the security posture that we have in place that
> prevents
> > a compiler from being loaded on the systems.  Has anyone loaded this
> > patch to a system without a compiler and if so did you experience any
> > issues.
> > 
> Hmm, don't understand why a compiler would be necessary?
> I'll be trying this patch shortly on several Solaris 10 systems, so
> will let you know.
> Ray

More information about the bind-users mailing list