Scott Haneda talklists at
Wed Sep 1 22:26:13 UTC 2010

On Sep 1, 2010, at 11:26 AM, Josh Miller wrote:

> On 08/31/2010 12:10 PM, Scott Haneda wrote:
>> If anyone can point me to a simple tutorial, or explain how they managed to get this up and running on RHEL with a current version of BIND, I would appreciate any and all information that can be shared.  I will do my best to follow up with what I learn once this is all done so others can hopefully have an easier time.
> Hi Scott,
> I have just made a quick write-up of my use of Bind-DLZ on Centos 5.X. I would welcome any comments.

Thanks!  I don't think I will have much issue with the configuration, this is a second install as a slave to a master that resides elsewhere.  Probably the hardest part will be getting Mysql to replicate across a non local lan, but it should be not that terrible to get working.

My issue seems to be the actual install.

I am using this rpm:

When I run rpm -i on that it warns me about mysql-devel and posgresql-devel, so I installed mysql-devel and commented out the need for the postgresql-devel from the spec file.

Next up I run:
rpmbuild -bb /usr/src/redhat/SPECS/bind.spec

That command does not complete, and is also installing a chrooted BIND, which I don't want:
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.84489
+ umask 022
+ cd /usr/src/redhat/BUILD
+ export LANG
+ unset DISPLAY
+ cd /usr/src/redhat/BUILD
+ rm -rf bind-9.7.1-P2
+ /bin/gzip -dc /usr/src/redhat/SOURCES/bind-9.7.1-P2.tar.gz
+ tar -xf -
+ '[' 0 -ne 0 ']'
+ cd bind-9.7.1-P2
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ echo 'Patch #5 (bind-nonexec.patch):'
Patch #5 (bind-nonexec.patch):
+ patch -p1 -b --suffix .nonexec -s
+ echo 'Patch #10 (bind-9.5-PIE.patch):'
Patch #10 (bind-9.5-PIE.patch):
+ patch -p1 -b --suffix .PIE -s
+ echo 'Patch #16 (bind-9.3.2-redhat_doc.patch):'
Patch #16 (bind-9.3.2-redhat_doc.patch):
+ patch -p1 -b --suffix .redhat_doc -s
+ echo 'Patch #104 (bind-96-dyndb.patch):'
Patch #104 (bind-96-dyndb.patch):
+ patch -p1 -b --suffix .dyndb -s
+ echo 'Patch #111 (bind97-compat-default-keysdir.patch):'
Patch #111 (bind97-compat-default-keysdir.patch):
+ patch -p1 -b --suffix .compat-default-keysdir -s
+ echo 'Patch #101 (bind-96-old-api.patch):'
Patch #101 (bind-96-old-api.patch):
+ patch -p1 -b --suffix .old-api -s
+ mkdir bin/named-sdb
+ cp -r bin/named/ bin/named/ bin/named/bind.keys.h bin/named/bind9.xsl bin/named/bind9.xsl.h bin/named/ bin/named/builtin.c bin/named/client.c bin/named/config.c bin/named/control.c bin/named/controlconf.c bin/named/ bin/named/include bin/named/interfacemgr.c bin/named/listenlist.c bin/named/log.c bin/named/logconf.c bin/named/lwaddr.c bin/named/lwdclient.c bin/named/lwderror.c bin/named/lwdgabn.c bin/named/lwdgnba.c bin/named/lwdgrbn.c bin/named/lwdnoop.c bin/named/lwresd.8 bin/named/lwresd.c bin/named/lwresd.docbook bin/named/lwresd.html bin/named/lwsearch.c bin/named/main.c bin/named/main.c.dyndb bin/named/named.8 bin/named/named.8.redhat_doc bin/named/named.conf.5 bin/named/named.conf.docbook bin/named/named.conf.html bin/named/named.docbook bin/named/named.html bin/named/notify.c bin/named/query.c bin/named/server.c bin/named/server.c.compat-default-keysdir bin/named/server.c.dyndb bin/named/sortlist.c bin/named/statschannel.c bin/named/tkeyconf.c bin/named/tsigconf.c bin/named/unix bin/named/update.c bin/named/win32 bin/named/xfrout.c bin/named/zoneconf.c bin/named-sdb
+ echo 'Patch #11 (bind-9.3.2b2-sdbsrc.patch):'
Patch #11 (bind-9.3.2b2-sdbsrc.patch):
+ patch -p1 -b --suffix .sdbsrc -s
+ cp -fp contrib/sdb/ldap/ldapdb.c contrib/sdb/ldap/ldapdb.h bin/named-sdb
+ cp -fp contrib/sdb/pgsql/pgsqldb.c contrib/sdb/pgsql/pgsqldb.h bin/named-sdb
+ cp -fp contrib/sdb/sqlite/sqlitedb.c contrib/sdb/sqlite/sqlitedb.h bin/named-sdb
+ cp -fp contrib/sdb/dir/dirdb.c contrib/sdb/dir/dirdb.h bin/named-sdb
+ mkdir -p bin/sdb_tools
+ cp -fp /usr/src/redhat/SOURCES/ldap2zone.c bin/sdb_tools/ldap2zone.c
+ cp -fp /usr/src/redhat/SOURCES/ bin/sdb_tools/
+ cp -fp contrib/sdb/ldap/zone2ldap.1 contrib/sdb/ldap/zone2ldap.c bin/sdb_tools
+ cp -fp contrib/sdb/pgsql/zonetodb.c bin/sdb_tools
+ cp -fp contrib/sdb/sqlite/zone2sqlite.c bin/sdb_tools
+ echo 'Patch #12 (bind-9.5-sdb.patch):'
Patch #12 (bind-9.5-sdb.patch):
+ patch -p1 -b --suffix .sdb -s
+ echo 'Patch #17 (bind-9.3.2b1-fix_sdb_ldap.patch):'
Patch #17 (bind-9.3.2b1-fix_sdb_ldap.patch):
+ patch -p1 -b --suffix .fix_sdb_ldap -s
+ echo 'Patch #62 (bind-9.5-sdb-sqlite-bld.patch):'
Patch #62 (bind-9.5-sdb-sqlite-bld.patch):
+ patch -p1 -b --suffix .sdb-sqlite-bld -s
+ echo 'Patch #71 (bind-9.5-overflow.patch):'
Patch #71 (bind-9.5-overflow.patch):
+ patch -p1 -b --suffix .overflow -s
+ echo 'Patch #72 (bind-9.5-dlz-64bit.patch):'
Patch #72 (bind-9.5-dlz-64bit.patch):
+ patch -p1 -b --suffix .64bit -s
+ echo 'Patch #73 (bind-9.5-libidn.patch):'
Patch #73 (bind-9.5-libidn.patch):
+ patch -p1 -b --suffix .libidn -s
+ echo 'Patch #83 (bind-9.5-libidn2.patch):'
Patch #83 (bind-9.5-libidn2.patch):
+ patch -p1 -b --suffix .libidn2 -s
+ echo 'Patch #85 (bind-9.5-libidn3.patch):'
Patch #85 (bind-9.5-libidn3.patch):
+ patch -p1 -b --suffix .libidn3 -s
+ echo 'Patch #87 (bind-9.5-parallel-build.patch):'
Patch #87 (bind-9.5-parallel-build.patch):
+ patch -p1 -b --suffix .parallel -s
+ echo 'Patch #94 (bind95-rh461409.patch):'
Patch #94 (bind95-rh461409.patch):
+ patch -p1 -b --suffix .rh461409 -s
+ mkdir m4
+ echo 'Patch #99 (bind-96-libtool2.patch):'
Patch #99 (bind-96-libtool2.patch):
+ patch -p1 -b --suffix .libtool2 -s
+ echo 'Patch #102 (bind-95-rh452060.patch):'
Patch #102 (bind-95-rh452060.patch):
+ patch -p1 -b --suffix .rh452060 -s
+ echo 'Patch #106 (bind93-rh490837.patch):'
Patch #106 (bind93-rh490837.patch):
+ patch -p0 -b --suffix .rh490837 -s
+ echo 'Patch #107 (bind97-dist-pkcs11.patch):'
Patch #107 (bind97-dist-pkcs11.patch):
+ patch -p1 -b --suffix .dist-pkcs11 -s
+ echo 'Patch #109 (bind97-rh478718.patch):'
Patch #109 (bind97-rh478718.patch):
+ patch -p1 -b --suffix .rh478718 -s
+ echo 'Patch #110 (bind97-rh507429.patch):'
Patch #110 (bind97-rh507429.patch):
+ patch -p1 -b --suffix .rh507429 -s
+ :
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.45014
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd bind-9.7.1-P2
+ export LANG
+ unset DISPLAY
+ export 'CFLAGS= -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
+ CFLAGS=' -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
+ sed -i -e 's/RELEASEVER=\(.*\)/RELEASEVER=\1-RedHat-9.7.1-2.P2/' version
+ libtoolize -c -f
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
+ aclocal -I m4 --force warning: underquoted definition of NOM_PATH_FILE
 run info '(automake)Extending aclocal'
 or see
contrib/dlz/ warning: underquoted definition of DLZ_ADD_DRIVER
+ autoconf -f error: possibly undefined macro: AC_C_FLEXIBLE_ARRAY_MEMBER
     If this token and others are legitimate, please use m4_pattern_allow.
     See the Autoconf documentation.
error: Bad exit status from /var/tmp/rpm-tmp.45014 (%build)

RPM build errors:
   Bad exit status from /var/tmp/rpm-tmp.45014 (%build)
Scott (* For off-list contact, replace talklists@ with scott@ *)

More information about the bind-users mailing list