installing on SLES 10sp3

Lyle Giese lyle at
Thu Sep 9 16:19:29 UTC 2010

I am trying to install bind 9.7.1-P2 from source on a SLES 10 SP3 server.

When I run named from the command line, it runs, but fails to open and 
write any of the zone files it downloaded.

named -c /etc/named.conf   (yes I am running this a root)

The error is
Sep  9 10:40:05 linuxps named[30549]: transfer of 
'' from Transfer 
completed: 1 messages, 261 records, 5636 bytes, 0.116 secs (48586 bytes/sec)
Sep  9 10:40:05 linuxps named[30549]: zone sending notifies (serial 2010081601)
Sep  9 10:40:05 linuxps named[30549]: dumping master file: 
tmp-QJcEgeBZ3h: open: permission denied

There is never a path mentioned in the permission denied message and the 
zone files are not written out to disk.

I have set a directory in the options section:

Options {
    directory "/etc/named";

When I run named-checkconf against named.conf, it is always erroring out 
against this line(directory line), no matter what I put there or 
different syntax I insert.  And yes the directory really does exist.

named.conf: line 17: change directory to: '/etc/named' failed: file not 

named.conf:line 17: parse failed

What 'file' is named-checkconf looking for? Or is this a bogus error 
message?  Am I missing something else?  I am starting named as root, but 
appear to be getting permission issues.  It just does not make any sense 
right now.

Lyle Giese
LCR Computer Services, Inc.

More information about the bind-users mailing list