rndc: 'addzone' failed: permission denied

Fredrik Poller Fredrik.Poller at zetup.se
Wed Aug 17 13:24:33 UTC 2011


I'm trying to use the new addzone feature in rndc, but all I get is the following error message:

# rndc addzone 'example.com in external { type slave; file "example.com"; masters {; }; };'
rndc: 'addzone' failed: permission denied

rndc is configured and works well with other commands.

The bind log file doesn't tell me anything, despite increasing the trace level, it only acknowledges that the request was received. Running rndc with -V doesn't reveal anything useful.

I've tried with and without views, I've tried to add both master and slave zones with different filenames (both relative and full path). Out of desperation I've also instituted some very liberal file permissions on everything named related, but no luck.

Searching Google for "rndc: 'addzone' failed: permission denied" gives me no results (that's no as as in zero hits). Without quotes I get some hits, but nothing related to addzone.

Any help you can throw my way would be much appreciated! Thanks.

Best regards,
Fredrik Poller

More information about the bind-users mailing list