slave not updating or creating ofd zone files

Thu Mar 29 08:58:52 UTC 2012

Hello all i have what is to me a very strange bind 9 master slave transfer issue. 

When i update a zone file on the master the file updates correctly the notifies are sent and every thing seems to work perfectly except it transfers 0 bytes to the slave. Checking the slave confirms that indeed thier was no transfer and that the slave is still serving the old zone, i have gon as far as to completely delete the zone files from the slave and restart bind to my suprise it puts back all the old files. What is going on? Below is an example of one of the files that is not updating correctly there are many and some of file I have updated more recently are not even showing up in the logs of the server. 

On the server Ubuntu 8.04 LTS running BIND 9.4.2-P2.1 chrooted 
29-Mar-2012 06:03:39.461 general: info: zone : loaded serial 2012031501 
29-Mar-2012 06:03:39.614 notify: info: zone : sending notifies (serial 2012031501) 
29-Mar-2012 06:03:41.761 xfer-out: info: client view external: transfer of ' ': IXFR ended 

On the slave Ubuntu 10.04 LTS BIND 9.7.0-P1 
29-Mar-2012 00:03:41.666 general: info: zone : Transfer started. 
29-Mar-2012 00:03:41.706 xfer-in: info: transfer of ' ' from connected using 
29-Mar-2012 00:03:41.782 xfer-in: info: transfer of ' ' from Transfer completed: 0 messages, 1 records, 0 bytes, 0.076 secs (0 bytes/sec) 

As a side not i have both machines firewalled, but have port 53 open on both machines, and have ports set using this in these lines in the named.conf. file 
query-source address * port 53; 
transfer-source * port 53; 
notify-source * port 53; 

and see this in the dameon logs 
/etc/named.conf:9: using specific query-source port suppresses port randomization and can be insecure. 

Computer King CaN-Mail Surveillance King 

Surveillance - Sales Service - Hosting Backup 
Internet Based Surveillance Systems 
Custom Service Pac kages 
Secure IMAP Email - Automated Remote Backups - Photo Blogs - Online ERP and Accounting Packages 

Please visit to unsubscribe from this list 

bind-users mailing list 
bind-users at 

Enlarge your serial! 


I've tried that had this problem for awhile that is why serial was not dated today just picked a random zone file anyways i updated the serial with todays date and still get the same behaviour. Strange but the times are messed up i checked the time/date on both machines they are very similar what is with the wierd log times? 
29-Mar-2012 08:44:06.883 notify: info: zone sending notifies (serial 2012032901) 
29-Mar-2012 08:44:09.093 xfer-out: info: client view external: transfer of '': IXFR ended 

29-Mar-2012 02:41:45.829 xfer-in: info: transfer of '' from Transfer completed: 0 messages, 1 records, 0 bytes, 0.072 secs (0 bytes/sec) 

I get lots of these 0 bytes transfers everytime i try to edit a zone file now they keep poping up and zones never get updated on the slave it just keeps trying and getting 0 bytes 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the bind-users mailing list