Error running Configure with OpenSSL 1.1.0 and BIND 9.11.0rc1

John W. Blue at
Wed Aug 31 04:55:24 UTC 2016

Heh.  I did say "personally" and for me being locked out of doing what I want to do when I want to do it really helps me decide between something that is useful or junk.  And besides, I am cheap.


As an aside .. I remember I went into coworkers office for the first time.  It was like a small shrine to Steve Jobs and all things Apple.  There was even these small bonzi trees all over the place.  lol.  I had such a mental over-the-top-roll of the eyes that I just kind of stood there looking around.

That poor soul.

At least he seemed happy.

Sent from Nine<>

From: Vinícius Ferrão <ferrao at>
Sent: Aug 30, 2016 11:36 PM
To: John W. Blue
Cc: bind-users at
Subject: Re: Error running Configure with OpenSSL 1.1.0 and BIND 9.11.0rc1

Unnecessary hate.

OS X is a pretty standard Unix and it's POSIX certified instead of Linux for example.

BIND9 simply does not compile with OpenSSL 1.1 yet.

On Aug 31, 2016, at 01:20, John W. Blue < at< at>> wrote:

I personally avoid all Apple products like the plauge.  Sadly, a iPhone 6s was foisted upon me by my place of employment.  Piece of junk.  Hate it.


Surely you can find some normal hardware to install unix on and then BIND, right?  Or.  How about throwing up a VM on the Mac and using that to do testing inside of as opposed to the base OS?

Failing all of that have you tried installing something that is not an RC?


Sent from Nine<>

From: James Brown via bind-users <bind-users at<mailto:bind-users at>>
Sent: Aug 30, 2016 11:04 PM
To: bind-users at<mailto:bind-users at>
Subject: Error running Configure with OpenSSL 1.1.0 and BIND 9.11.0rc1

System is a Mac mini (late-2009) running a new install of Mac OS X 10.11.6.

Installed OpenSSL 1.1.0 using:
./Configure --prefix=/usr/local shared darwin64-x86_64-cc enable-ec_nistp_64_gcc_128 no-ssl2 no-ssl3
make depend
make test
sudo make install

No problems encountered. Then I tried to install BIND 9.11.0rc1 with:

./configure --with-atf

It failed with:

checking for sched_yield... yes
checking for pthread_yield... no
checking for pthread_yield_np... yes
checking for sysconf... yes
checking for libtool... no
checking for OpenSSL library... using OpenSSL from /usr/local/lib and /usr/local/include
checking whether linking with OpenSSL works... yes
checking whether linking with OpenSSL requires -ldl... unknown

Can anyone help me with this?


Please visit to unsubscribe from this list

bind-users mailing list
bind-users at<mailto:bind-users at>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the bind-users mailing list