delegation broken after migrating to new BIND config

blrmaani blrmaani at
Fri Dec 9 04:09:02 UTC 2016

I migrated our bind resolvers to a new config (new named.conf) and I see delegation broken. How do I trouble-shoot?

- The resolvers (are slaves) and are authoritative for and
- the resolvers forward queries to our companies DNS to resolve external names like, etc
- The resolver has views and match same destinations in both old and new config.

the zone is which contains a record as below: NS    A

dig @localhost  # this doesn't give any hint.

Here are the steps I tried and still no luck:

1. Compared zone transfer output of before and after migration, both look similar and contains delegation entry.

2. I tried this and works ok (before and after migration) in both cases indicating that the NS
    is still reachable and respond to DNS queries before and after migration.

## Returns as expected  ACLs broken

3. Checked cache dump file (db file) - I see the following entry when it works (pre-migration):
cache_dump.db:;  [srtt 0] [flags 00000000] [ttl 1797]

however, the above entry is missing after I migrate to new BIND config.

I compared the BIND configs before and after migration and I don't see any significant difference which might cause this issue.. wondering what am I missed?


More information about the bind-users mailing list