bind-9.11.0-P2 on Debian 9.0 (stretch)

Reindl Harald h.reindl at
Thu Jan 26 15:36:59 UTC 2017

Am 26.01.2017 um 16:30 schrieb Wolfgang Riedel:
> I agree and also didn’t like it but I had been told that OpenSSL 1.1 is currently not supported because they made backwards-incompatible API changes and this is the default on Debian stretch. That’s the reason why I compiled from source to get to 1.0 < 1.1

but you should never use /usr for anything which don't end in a package
especially playing around with openssl will sooner ot later break your 
whole system and then named is your smallest problem

additionall your major mistake here was that you *first* tried something 
dangerous at your own while ask before would have leaded someone 
pointing you to

for Fedora 26 (Rawhide) a similar compat-package exists

>> On 26 Jan 2017, at 16:22PM, Tony Finch <dot at> wrote:
>> Wolfgang Riedel <wriedel at> wrote:
>>> Just wonder if someone had success compiling bind-9.11.0-P2 on Debian 9.0 (stretch)?
>> I haven't tried it myself.
>>> 1) OpenSSL dependency dance
>>> I removed OpenSSL 1.1 and compiled OpenSSL 1.0.2e from source
>> You'll probably have better luck installing Debian's libssl1.0-dev and
>> related packages, rather than installing it yourself. Plain libssl-dev in
>> Stretch is OpenSSL 1.1.
>> If you install stuff yourself from source then it is particularly unwise
>> to put it in /usr where it'll collide with files managed by dpkg - put it
>> in /usr/local or /opt.

More information about the bind-users mailing list