Email & PTR Issues

James Pifer jep at
Tue Nov 7 15:31:29 UTC 2017

Hello. I'm looking for help with an issue I've been fighting for some time.

Running BIND 9.9.
Forwarding UDP & TCP Port 53 through firewall.

I have issues emailing to certain domains. I use my own mail server to 
deliver mail. It is currently not sending through SMTP Relay. The 
failure says that I have a missing PTR record. For example:

     said: 550 5.7.1 Connections not accepted from servers without a valid
     sender domain.alph151 Fix reverse DNS for (in reply to
     FROM command)

If I do a test on mxtoolbox it also says I have the issue:

If I look at dnsstuff and do a test on Mail Server Test Center and run 
selected tests under the MX Dashboard it gives a DNS Mismatch.

BUT, If I look at dnsstuff,com and do a reverse lookup test, that seems 

Also, from a pc somewhere else on the internet, if you change your DNS 
server to mine (or use nslookup) it resolves the reverse entry ok.


 > server
Default Server:  []

Server:  []



If anyone has any helpful suggestions it is appreciated.

I also tried moving my DNS to the provider I purchased my domain name 
from thinking that would be an easy fix. They don't support PTR records 
and actually had no clue what they even were.

I've also tried configuring my mail servers to use ATT's SMTP Relay, but 
so far I've been unsuccessful getting it to send at all. The emails keep 
getting deferred. Obviously not an issue for anyone on this list. Just 
providing info.


More information about the bind-users mailing list