PRNG not seeded, service won't start

Howard, Christopher Christopher-Howard at
Tue Sep 18 13:41:29 UTC 2018

I've tried this one. It doesn't work. There is plenty of entropy on the box, but it still won't start with the same error.


On Tue, 2018-09-18 at 01:22 +0200, Reindl Harald wrote:

Am 18.09.18 um 01:11 schrieb Howard, Christopher:

I'm attempting to upgrade from bind 9.10.4-P8 to 9.12.2-P1 and the

service refuses to start. This is on a CentOS 6.10 machine. I ran into

the same issue on CentOS 7 and was able to fix it by making sure that

rngd is running before the named service starts. That same fix is not

working for CentOS 6. I'm at a loss as to how to fix this and Google is

failing me now.

The error in the log says:

Sep 17 18:59:08 nsm named[3926]: openssl_link.c:296: fatal error:

Sep 17 18:59:08 nsm named[3926]: OpenSSL pseudorandom number generator

cannot be initialized (see the `PRNG not seeded' message in the OpenSSL FAQ)

Does any one have any ideas of what I'm missing or what I can do to

resolve this (besides upgrading this box to CentOS 7)?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the bind-users mailing list