Upgrading from BIND 9.14.9 to 9.16.3

Ondřej Surý ondrej at isc.org
Wed May 27 16:06:12 UTC 2020


I did reply to you on the issue you created, I’ll copy it here for clarity:

> You should evaluate the contents of config.log file for proper diagnostics.
> That said, you are most probably missing pkg-config configuration, try setting PKG_CONFIG_PATH environment variable to a directory where libuv.pc resides.
> pkg-config --list-all should list libuv.

e.g. try

$ export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
$ pkg-config --list-all | grep libuv

It should say something like this:

libuv                     libuv - multi-platform support library with a focus on asynchronous I/O.

If that doesn’t work, you really need to look into config.log, it has all or most of the information needed to properly debug the issue.

Ondřej Surý
ondrej at isc.org

> On 27 May 2020, at 17:57, DeCaro, James John (Jim) CIV DISA FE (USA) via bind-users <bind-users at lists.isc.org> wrote:
> Solaris Unix x86 64 bit VM on VMware
> I discovered a new dependency: libuv.  libuv also has dependencies: automake  m4   libtool   autoconf.  I installed the dependencies, then tried installing various versions of libuv using sh autogen.sh -- then ./configure - make - make check - make install to install libuv.  Back to installing BIND 9.16.3: ./configure   > received an error: 'configure: error: libuv not found'.  I had tried installing libuv 1.0.0.  1.38.0. and 1.9.1  --same result.
> libuv files are present in:
> $ find / -name libuv* -print
> /usr/local/lib/libuv.so
> /usr/local/lib/libuv.la
> /usr/local/lib/libuv.so.1
> /usr/local/lib/libuv.a
> /usr/local/lib/libuv.so.1.0.0
> /usr/local/lib/pkgconfig/libuv.pc
> /usr/include/sys/libuvfs_ki.h
> /usr/include/libuvfs.h
> /usr/lib/amd64/libuvfs.so
> /usr/lib/amd64/libuvfs.so.1
> I am not clear how to fix this--seems like the ./configure command needs an option to discover libuv but I am not sure.
> Any help would be appreciated.
> Jim
> _______________________________________________
> Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list
> ISC funds the development of this software with paid support subscriptions. Contact us at https://www.isc.org/contact/ for more information.
> bind-users mailing list
> bind-users at lists.isc.org
> https://lists.isc.org/mailman/listinfo/bind-users

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 963 bytes
Desc: Message signed with OpenPGP
URL: <https://lists.isc.org/pipermail/bind-users/attachments/20200527/7c782824/attachment.bin>

More information about the bind-users mailing list