BIND 9.16.13 and Mac OS X 10.13.6 - problems with ./configure

Larry Stone lstone19 at
Fri Mar 26 03:58:56 UTC 2021

I’ve been building BIND on MacOS for years (currently on Catalina but has worked on almost the entire Mac OS X series.

> On Mar 25, 2021, at 7:50 PM, Paul Cizmas <cizmas at> wrote:
> I am new to BIND and I am trying to install version 9.16.13 on a Mac OS X 10.13.6.
> I downloaded version 9.16.13 and, following the suggestions from, I am trying to configure using
> ./configure --enable-symtable=none --infodir="/usr/share/info" --sysconfdir="/etc" --localstatedir="/var" --enable-atomic="no" --with-gssapi=yes --with-libxml2=no

I don’t know that site and I don’t know what most of the those options do. A simple ./configure has almost always worked for me.

> This fails because of libuv
> checking for pthread_set_name_np... no
> checking for pthread_np.h... no
> checking for libuv... checking for libuv >= 1.0.0... no
> configure: error: libuv not found
> I have libuv installed, however.  It is version 1.41.0.

Is libuv where the BIND configure is looking for it? My libuv files are in /usr/local/lib. I have libuv 1.35 (doubt the version is making a difference) and it looks like I installed it a year ago.

Are you using something like homebrew or macports? I don’t as I was already too established doing everything from scratch when I learned about them. But I believe at least one of them if not both use their own set of directories so something built with one of them will not be found by something coming from the other or done from scratch. Those instructions from appear to be doing a “from scratch” version so if you installed libuv with homebrew or macports, I doubt the instructions will find it.

Larry Stone
lstone19 at

More information about the bind-users mailing list