BIND 9.16.13 and Mac OS X 10.13.6 - problems with ./configure

Paul Cizmas cizmas at
Fri Mar 26 20:06:19 UTC 2021

Tony, thank you!  I ran 'dig @localhost version.bind ch txt’ and got

~$ dig @localhost version.bind ch txt
md5.c:96: fatal error: RUNTIME_CHECK(pk11_get_session(ctx, OP_DIGEST, 1, 0, 0, ((void *)0), 0) == 0) failed
Abort trap: 6

I do not know what this means.

I then ran 'which named’ and it is


When I ran rndc status I got

~$ rndc status
rndc: error: open: /Library/Server/named/rndc.key: permission denied
rndc: could not load rndc configuration

Thank you,

> On Mar 26, 2021, at 1:44 PM, Tony Finch <dot at> wrote:
> Paul Cizmas <cizmas at> wrote:
>> ~$ named -v
>> BIND 9.9.7-P3 (Extended Support Version)
> What's probably happening here is that the BIND on your $PATH isn't
> necessarily the BIND that homebrew installed and (hopefully) is running.
> You can run `dig @localhost version.bind ch txt` to see what the running
> server reports as its version.
> You can run `which named` to find out where it is finding 9.9.7.
> If you run `rndc status` it should fail, because of the mismatched
> installations (I expect your 9.9.7 will not look for the rndc key in the
> same place as 9.16.3) but `/usr/local/opt/bind/sbin/rndc status` ought to
> work and tell you about the running 9.16.3.
> Tony.
> -- 
> f.anthony.n.finch  <dot at>;!!KwNVnqRv!X3SMvugQcNKGxCiqE5_jRKoYHw1W0s4vgKKIp5wzN-eZZHZJyrih8gMHTHqvak0$ 
> Great Orme Head to the Mull of Galloway: Southwest veering west 6 to
> gale 8, backing southwest 5 to 7 later. Moderate, occasionally rough.
> Squally showers, rain later. Good, occasionally moderate.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the bind-users mailing list