Are there NS records and/or zone forwarding for the <a href="http://10.131.10.0">10.131.10.0</a>?<br>If there is the servers will look to the most specfic domain.<br><br>-- <br>-Ben Croswell<br><br><div class="gmail_quote">
On Thu, Dec 11, 2008 at 4:38 PM, Todd Snyder <span dir="ltr"><<a href="mailto:tsnyder@rim.com">tsnyder@rim.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Good day,<br>
<br>
We are working on an odd issue.  I can provide more detail as necessary,<br>
but don't want to fill this email with snips of useless stuff.  All<br>
IP's/names provided are made up, as they don't matter in this problem as<br>
far as I can tell.  This is more a functional question than a specific<br>
operating question.<br>
<br>
We have 2 servers acting as a slave for the zone "10.in-addr.arpa".  The<br>
master(s) for this server are 2 Windows AD servers.  Our servers (all<br>
bind9.4 of some variety) are doing zone transfers fine, and we're<br>
getting whatever is in the zone.<br>
<br>
We've run in to a couple IP's that when we dig them on these slaves,<br>
they are timing out.  They are in a specific location, which we have<br>
determined are firewalled differently.<br>
<br>
For example, we are doing a dig for <a href="http://10.131.10.1" target="_blank">10.131.10.1</a> against these 2<br>
different locations.  In one location, we get an answer quickly.  In the<br>
other, it times out.  The problem in our case is that in one location,<br>
the slave we're querying can't reach anything but the masters.<br>
<br>
What we've figured out is that the 10.in-addr.arpa zone doesn't contain<br>
EVERY 10. address we thought, but is missing some.  In this case, our<br>
slaved zone doesn't have <a href="http://10.131.10.1" target="_blank">10.131.10.1</a>.  But, instead of the slave server<br>
(which should be authortative) returning an "I don't know" error, it<br>
appears to be doing a recusive query.  Against what, we're not 100% sure<br>
of yet.  Well, we know which server, because DIG tells us, but we aren't<br>
sure why that one.<br>
<br>
When I look at the 10.in-addr.arpa zone, there are approximately 20 NS<br>
records for other AD servers.  My speculation is that the slave we're<br>
querying is recusively looking to one of the servers returned in the<br>
additional section?  This behaviour seems odd to us, and therein lies my<br>
question.<br>
<br>
Does doing a reverse lookup (dig -x) cause the queried server to behave<br>
differently than a forward lookup?  My slave server is technically<br>
authoritative for the 10.in-addr.arpa zone, but it is still recusively<br>
going to another server to find an answer.  Why?  Is this because we<br>
have defined the zone as 10.in-addr.arpa instead of creating/slaving<br>
more specific zones (ie: 10.131.10.in-addr.arpa)?  How can we control<br>
this behaviour?<br>
<br>
Thank you for any light you can shed on this - we're confident we know<br>
what is going on, but we can't figure out why the server behaves<br>
differently for reverse zones than it would for forward zones.<br>
<br>
Cheers,<br>
<br>
Todd.<br>
<br>
<br>
------------------------------<br>
Todd Snyder<br>
Data Networks Tools<br>
bb.226.338.2617<br>
Always On, Always Connected.<br>
<br>
<br>
---------------------------------------------------------------------<br>
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.<br>

_______________________________________________<br>
bind-users mailing list<br>
<a href="mailto:bind-users@lists.isc.org">bind-users@lists.isc.org</a><br>
<a href="https://lists.isc.org/mailman/listinfo/bind-users" target="_blank">https://lists.isc.org/mailman/listinfo/bind-users</a><br>
</blockquote></div><br><br clear="all"><br><br>