<div dir="ltr"><div>I put together a simple working DNS server and called it new-dns2 with the IP address of 206.117.115.93. My configuration files follow:</div><div> </div><div>[root@new-dns2 ~]# cat /etc/named.conf<br>options {<br>         directory "/var/named";<br> };</div><div>zone "0.0.127.in-addr.arpa" {<br>        type master;<br>        file "db.127.0.0";<br>};<br>[root@new-dns2 ~]# cat /var/named/db.127.0.0<br>$TTL 3D<br>@               IN      SOA     <a href="http://new-dns1.ci.glendale.ca.us">new-dns1.ci.glendale.ca.us</a> <a href="http://mchavoshi.glendaleca.gov">mchavoshi.glendaleca.gov</a>. (<br>                                1       ; Serial<br>                                8H      ; Refresh<br>                                2H      ; Retry<br>                                4W      ; Expire<br>                                1D)     ; Minimum TTL<br>                        NS      <a href="http://new-dns1.ci.glendale.ca.us">new-dns1.ci.glendale.ca.us</a>.<br>1                       PTR     localhost.<br>[root@new-dns2 ~]#</div><div> </div><div>So, when I query my new DNS server from itself (206.117.115.93), it resolves the name to an IP, but when I query my new DNS server from another Linux box, it fails with the following error message.</div><div> </div><div>[root@new-dns2 ~]# nslookup <a href="http://google.com">google.com</a> 206.117.115.93<br>Server:         206.117.115.93<br>Address:        206.117.115.93#53</div><div>Non-authoritative answer:<br>Name:   <a href="http://google.com">google.com</a><br>Address: 216.58.217.206</div><div>[root@new-dns2 ~]#</div><div> </div><div>[root@oragrid01 ~]# nslookup <a href="http://google.com">google.com</a> 206.117.115.93<br>Server:         206.117.115.93<br>Address:        206.117.115.93#53</div><div>** server can't find <a href="http://google.com">google.com</a>: REFUSED</div><div>[root@oragrid01 ~]#</div><div> </div><div>I have stopped FireWall on new-dns2, my DNS server:</div><div> </div><div>[root@new-dns2 ~]# service iptables status<br>iptables: Firewall is not running.<br>[root@new-dns2 ~]#</div><div> </div><div>Can someone please tell me what might be the problem?</div><div> </div><div>Many thanks in advance and have a wonderful day/night.</div><div> </div><div>Sincerely,</div><div>Samad Agha</div></div>