<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:x="urn:schemas-microsoft-com:office:excel" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;
        mso-fareast-language:EN-US;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri",sans-serif;
        mso-fareast-language:EN-US;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-CA" link="#0563C1" vlink="#954F72">
<div class="WordSection1">
<p class="MsoNormal">Good day,<o:p></o:p></p>
<p class="MsoNormal">I’ve been having an interesting issue with BIND and wondering if anyone has had this before or knows how to fix it.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">The issue is,<o:p></o:p></p>
<p class="MsoNormal">I have 2 recursive/caching DNS servers running BIND 9.9.4-RedHat-9.9.4-51.el7, which are slow to query for this particular domain.<o:p></o:p></p>
<p class="MsoNormal">Noaa.gov (as well as its sub domains. Specifically – <a href="http://www.nhc.noaa.gov">
www.nhc.noaa.gov</a> )<o:p></o:p></p>
<p class="MsoNormal">By slow I mean, it takes approximately 3500ms to query while most other domains take less than 100ms to query.<o:p></o:p></p>
<p class="MsoNormal">What’s worst, the domains (noaa.gov) becomes unqueriable after a few hours or a day and I need to clear the DNS servers cache to allow it to work again.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">The domains have very very low TTL’s (30s) and use DNSsec<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Error:<o:p></o:p></p>
<p class="MsoNormal">##dig www.nhc.noaa.gov<o:p></o:p></p>
<p class="MsoNormal">;; Got answer:<o:p></o:p></p>
<p class="MsoNormal">;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52364<o:p></o:p></p>
<p class="MsoNormal">;; flags: qr rd ra; QUERY: 1, ANSWER: 12, AUTHORITY: 3, ADDITIONAL: 7<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><span lang="FR-CA">;; OPT PSEUDOSECTION:<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FR-CA">; EDNS: version: 0, flags:; udp: 4096<o:p></o:p></span></p>
<p class="MsoNormal">;; QUESTION SECTION:<o:p></o:p></p>
<p class="MsoNormal">;www.nhc.noaa.gov.              IN      A<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><u>Fixes I have attempted so far:<o:p></o:p></u></p>
<p class="MsoNormal"><i>Reboot servers (2 centos servers running on vmware)<o:p></o:p></i></p>
<p class="MsoNormal"><i>Update system<o:p></o:p></i></p>
<p class="MsoNormal"><i>Try a default config file<o:p></o:p></i></p>
<p class="MsoNormal"><i>Updated vmware tools<o:p></o:p></i></p>
<p class="MsoNormal"><i>Clear DNS cache (temporary fix)<o:p></o:p></i></p>
<p class="MsoNormal"><i>Checked firewall for abnormal data<o:p></o:p></i></p>
<p class="MsoNormal"><i>Updated root hints<o:p></o:p></i></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><u>Config:<o:p></o:p></u></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><span lang="FR-CA">acl internal {<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FR-CA">        *<b>removed</b>*;<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FR-CA">       localhost;<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FR-CA">        };<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FR-CA"><o:p> </o:p></span></p>
<p class="MsoNormal"><span lang="FR-CA">options {<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FR-CA">        listen-on port 53 { *<b>removed</b>*;<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FR-CA">                            127.0.0.1;<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FR-CA">;<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FR-CA">                           };<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FR-CA">        listen-on-v6 port 53 { none;<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FR-CA">                               </span>#::1;<o:p></o:p></p>
<p class="MsoNormal">                              };<o:p></o:p></p>
<p class="MsoNormal">        directory       "/var/named";<o:p></o:p></p>
<p class="MsoNormal">        dump-file       "/var/named/data/cache_dump.db";<o:p></o:p></p>
<p class="MsoNormal">        statistics-file "/var/named/data/named_stats.txt";<o:p></o:p></p>
<p class="MsoNormal">        memstatistics-file "/var/named/data/named_mem_stats.txt";<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">        dnssec-enable no;<o:p></o:p></p>
<p class="MsoNormal">        dnssec-validation no;<o:p></o:p></p>
<p class="MsoNormal">        dnssec-lookaside auto;<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">// Conform to RFC1035<o:p></o:p></p>
<p class="MsoNormal">    auth-nxdomain no;<o:p></o:p></p>
<p class="MsoNormal"><span lang="FR-CA"><o:p> </o:p></span></p>
<p class="MsoNormal">// Allowed Port Ranges<o:p></o:p></p>
<p class="MsoNormal">    use-v4-udp-ports { range 32768 65535; };<o:p></o:p></p>
<p class="MsoNormal">    use-v6-udp-ports { range 32768 65535; };<o:p></o:p></p>
<p class="MsoNormal">    recursive-clients 15000;<o:p></o:p></p>
<p class="MsoNormal">    server-id none;<o:p></o:p></p>
<p class="MsoNormal">    version none;<o:p></o:p></p>
<p class="MsoNormal">    interface-interval 0;<o:p></o:p></p>
<p class="MsoNormal">    allow-query { internal;<o:p></o:p></p>
<p class="MsoNormal">                  };<o:p></o:p></p>
<p class="MsoNormal">      allow-recursion { internal;<o:p></o:p></p>
<p class="MsoNormal">                      };<o:p></o:p></p>
<p class="MsoNormal">     max-ncache-ttl 3600;<o:p></o:p></p>
<p class="MsoNormal">     allow-query-cache { internal;<o:p></o:p></p>
<p class="MsoNormal">                        };<o:p></o:p></p>
<p class="MsoNormal">        };<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">logging {<o:p></o:p></p>
<p class="MsoNormal">        channel default_debug {<o:p></o:p></p>
<p class="MsoNormal">                  syslog local4;<o:p></o:p></p>
<p class="MsoNormal">                  severity debug;<o:p></o:p></p>
<p class="MsoNormal">        };<o:p></o:p></p>
<p class="MsoNormal">};<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">zone "." IN {<o:p></o:p></p>
<p class="MsoNormal">        type hint;<o:p></o:p></p>
<p class="MsoNormal">        file "named.ca";<o:p></o:p></p>
<p class="MsoNormal">};<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">include "/etc/named.rfc1912.zones";<o:p></o:p></p>
</div>
</body>
</html>