<html><head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class=""><div class=""><br class=""></div><div class="">OK. Before I did not give you the full picture because I did not want to be to verbose :-)</div><div class=""><br class=""></div><div class="">It should have been</div><div class=""><div style="margin: 0px; font-stretch: normal; line-height: normal; font-family: Menlo; color: rgb(193, 11, 0); background-color: rgb(255, 255, 255);" class=""><span style="color: rgb(202, 6, 91);" class=""><b class=""><br class=""></b></span></div><div style="margin: 0px; font-stretch: normal; line-height: normal; font-family: Menlo; color: rgb(193, 11, 0); background-color: rgb(255, 255, 255);" class=""><span style="color: rgb(202, 6, 91);" class=""><b class="">export</b></span><span style="color: rgba(0, 0, 0, 0.85);" class=""> SERVERPLUS_DIR=</span>"/opt/serverplus”</div></div><div style="margin: 0px; font-stretch: normal; line-height: normal; font-family: Menlo; color: rgb(193, 11, 0); background-color: rgb(255, 255, 255);" class=""><div style="margin: 0px; font-stretch: normal; line-height: normal; color: rgba(0, 0, 0, 0.85);" class="">git clone <a href="https://gitlab.isc.org/isc-projects/bind9.git" class="">https://gitlab.isc.org/isc-projects/bind9.git</a></div><div style="margin: 0px; font-stretch: normal; line-height: normal; color: rgba(0, 0, 0, 0.85);" class=""><span style="color: rgb(202, 6, 91);" class=""><b class="">cd</b></span> bind9</div><div style="margin: 0px; font-stretch: normal; line-height: normal; color: rgba(0, 0, 0, 0.85);" class="">autoreconf -<span style="color: rgb(202, 6, 91);" class=""><b class="">if</b></span></div><div style="margin: 0px; font-stretch: normal; line-height: normal; color: rgba(0, 0, 0, 0.85);" class="">LIBUV_LIBS=<span style="color: rgb(193, 11, 0);" class="">"-L</span>$SERVERPLUS_DIR<span style="color: rgb(193, 11, 0);" class="">/dependencies/libuv/lib"</span> LIBUV_CFLAGS=<span style="color: rgb(193, 11, 0);" class="">" -I</span>$SERVERPLUS_DIR<span style="color: rgb(193, 11, 0);" class="">/dependencies/libuv/include"</span> CPPFLAGS=<span style="color: rgb(193, 11, 0);" class="">" -I</span>$SERVERPLUS_DIR<span style="color: rgb(193, 11, 0);" class="">/dependencies/libuv/include"</span> LDFLAGS=<span style="color: rgb(193, 11, 0);" class="">'-flat_namespace -force_flat_namespace'</span> ./configure --prefix=<span style="color: rgb(193, 11, 0);" class="">"</span>$SERVERPLUS_DIR<span style="color: rgb(193, 11, 0);" class="">"</span> --with-openssl=<span style="color: rgb(193, 11, 0);" class="">"</span>$SERVERPLUS_DIR<span style="color: rgb(193, 11, 0);" class="">/dependencies/openssl"</span> --disable-pthread-rwlock --with-libxml2=no --<span style="color: rgb(202, 6, 91);" class=""><b class="">enable</b></span>-full-report</div><div class=""><br class=""></div></div><div class=""><br class=""></div><div class=""><br class=""></div><div class="">After Ondrej suggestion I have removed all the LIBUV_XXX env variables and change to</div><div class=""><br class=""></div><div class=""><div style="margin: 0px; font-stretch: normal; line-height: normal; font-family: Menlo; color: rgba(0, 0, 0, 0.85); background-color: rgb(255, 255, 255);" class="">PGK_CONFIG_PATH=<span style="color: rgb(193, 11, 0);" class="">"/opt/build/tools/pkg-config"</span> PKG_CONFIG_PATH=<span style="color: rgb(193, 11, 0);" class="">"</span>$SERVERPLUS_DIR<span style="color: rgb(193, 11, 0);" class="">/dependencies/libuv/lib/pkgconfig"</span> ./configure --prefix=<span style="color: rgb(193, 11, 0);" class="">"</span>$SERVERPLUS_DIR<span style="color: rgb(193, 11, 0);" class="">"</span> --with-openssl=<span style="color: rgb(193, 11, 0);" class="">"</span>$SERVERPLUS_DIR<span style="color: rgb(193, 11, 0);" class="">/dependencies/openssl"</span> --disable-pthread-rwlock --with-libxml2=no --<span style="color: rgb(202, 6, 91);" class=""><b class="">enable</b></span>-full-report</div></div><div class=""><br class=""></div><div class=""><br class=""></div><div class="">I did not had to change the source code :-) and after deploying no more complaints from dylib! named is running fine!</div><div class=""><br class=""></div><div class="">All worked! Thank you very much for the help!</div><div class=""><br class=""></div><div class="">Thanks again,</div><div class=""><br class=""></div><div class="">Eddy</div><div class=""><br class=""></div><br class=""><div><br class=""><blockquote type="cite" class=""><div class="">On Apr 28, 2020, at 12:22 PM, Ondřej Surý <<a href="mailto:ondrej@isc.org" class="">ondrej@isc.org</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><div class="">LIBUV_LIBS="-L$/dependencies/libuv/lib“<br class=""><br class="">JFTR this part of the line is wrong as it actually doesn’t contain the library itself (just LDFLAGS).<br class="">You should really use the pkgconfig.<br class=""><br class="">Ondrej<br class="">--<br class="">Ondřej Surý<br class=""><a href="mailto:ondrej@isc.org" class="">ondrej@isc.org</a><br class=""><br class=""><blockquote type="cite" class="">On 28 Apr 2020, at 19:36, Eddy Hahn <eddyhahn@hotmail.com> wrote:<br class=""><br class="">LIBUV_LIBS="-L$/dependencies/libuv/lib"<br class=""></blockquote><br class=""></div></div></blockquote></div><br class=""></body></html>