<html><head><meta http-equiv="content-type" content="text/html; charset=utf-8"></head><body dir="auto">See <a href="https://gitlab.isc.org/isc-projects/bind9/-/issues/2667">https://gitlab.isc.org/isc-projects/bind9/-/issues/2667</a><br><br><div dir="ltr"><div>--</div>Ondřej Surý — ISC (He/Him)<div><br></div><div>My working hours and your working hours may be different. Please do not feel obligated to reply outside your normal working hours.</div></div><div dir="ltr"><br><blockquote type="cite">On 6. 5. 2021, at 18:48, DeCaro, James John (Jim) CIV DISA FE (USA) via bind-users <bind-users@lists.isc.org> wrote:<br><br></blockquote></div><blockquote type="cite"><div dir="ltr"><span>Hello,</span><br><span></span><br><span>I have what is probably a very rudimentary question, but I am stuck.</span><br><span></span><br><span>I am attempting to upgrade BIND on a Solaris 11.4 x86 virtual platform.  I have installed BIND successfully up to version 9.16.12 using  ./configure --enable-full-report --with-gssapi=krb5-config --sysconfdir=/etc --with-openssl=/usr/local --localstatedir=/var --enable-fixed-rrset  </span><br><span></span><br><span>I also added environment variables: export LDFLAGS="-L/usr/local/lib -R/usr/local/lib"  [and]  export PKG_CONFIG_PATH="usr/lib/pkgconfig:/usr/local/lib/pkgconfig (for libuv)</span><br><span></span><br><span>This time ./configure aborts with errors related to linking gssapi to kerberos</span><br><span></span><br><span>checking krb5.h presence... yes</span><br><span>checking for krb5.h... yes</span><br><span>checking krb5-config linking as -lkrb5 -lk5crypto -lcom_err... krb5-config: could not determine proper GSSAPI linkage</span><br><span>checking for GSSAPI library, non krb5-config method... looking in /usr/lib</span><br><span>checking for gssapi.h... (cached) yes</span><br><span>checking for gssapi/gssapi.h... (cached) yes</span><br><span>checking gssapi_krb5.h usability... no</span><br><span>checking gssapi_krb5.h presence... no</span><br><span>checking for gssapi_krb5.h... no</span><br><span>checking gssapi/gssapi_krb5.h usability... no</span><br><span>checking gssapi/gssapi_krb5.h presence... no</span><br><span>checking for gssapi/gssapi_krb5.h... no</span><br><span>checking for krb5.h... (cached) yes</span><br><span>checking for krb5/krb5.h... (cached) yes</span><br><span>checking kerberosv5/krb5.h usability... no</span><br><span>checking kerberosv5/krb5.h presence... no</span><br><span>checking for kerberosv5/krb5.h... no</span><br><span>checking linking as -lgssapi_krb5... no</span><br><span>checking linking as -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err... no</span><br><span>checking linking as -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lresolv... no</span><br><span>checking linking as -lgssapi... no</span><br><span>checking linking as -lgssapi -lkrb5 -ldes -lcrypt -lasn1 -lroken -lcom_err... no</span><br><span>checking linking as -lgssapi -lkrb5 -lcrypt -lasn1 -lroken -lcom_err... no</span><br><span>checking linking as -lgssapi -lkrb5 -lgssapi_krb5 -lcrypt -lasn1 -lroken -lcom_err... no</span><br><span>checking linking as -lgssapi -lkrb5 -lhx509 -lcrypt -lasn1 -lroken -lcom_err... no</span><br><span>checking linking as -lgss -lkrb5... no</span><br><span>configure: error: could not determine proper GSSAPI linkage</span><br><span></span><br><span>I am looking all through the internet, the config.log, README etc. and I can't seem to find a solution. </span><br><span>krb5.h is located at </span><br><span>/usr/include/kerberosv5/krb5/krb5.h</span><br><span>/usr/include/kerberosv5/krb5.h</span><br><span>/usr/lib/krb5/krb5.h  </span><br><span></span><br><span>I am pretty sure it is a matter of setting the correct path variable, but I am new at this and I can't figure it out yet.  Any help would be appreciated.</span><br><span></span><br><span>Jim </span><br><span></span><br><span>_______________________________________________</span><br><span>Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list</span><br><span></span><br><span>ISC funds the development of this software with paid support subscriptions. Contact us at https://www.isc.org/contact/ for more information.</span><br><span></span><br><span></span><br><span>bind-users mailing list</span><br><span>bind-users@lists.isc.org</span><br><span>https://lists.isc.org/mailman/listinfo/bind-users</span><br></div></blockquote></body></html>