<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<!--[if !mso]><style>v\:* {behavior:url(#default#VML);}
o\:* {behavior:url(#default#VML);}
w\:* {behavior:url(#default#VML);}
.shape {behavior:url(#default#VML);}
</style><![endif]--><style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;
        mso-fareast-language:EN-US;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
span.EmailStyle20
        {mso-style-type:personal-reply;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:70.85pt 2.0cm 70.85pt 2.0cm;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-GB" link="#0563C1" vlink="#954F72" style="word-wrap:break-word">
<div class="WordSection1">
<p class="MsoNormal">Hi Sami,<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Could you try changing the number of vCPUs to either 6, 7, 9, or 10 and see if it then starts OK? If that works then you can either leave it like that or we can help you with a way to have BIND run a specific number of vCPU cores while
 you put the VM back to 8 vCPUs.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Best,<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<div>
<p class="MsoNormal"><span style="mso-fareast-language:EN-GB">Richard.<o:p></o:p></span></p>
</div>
<p class="MsoNormal"><o:p> </o:p></p>
<div>
<div style="border:none;border-top:solid #E1E1E1 1.0pt;padding:3.0pt 0cm 0cm 0cm">
<p class="MsoNormal"><b><span lang="EN-US" style="mso-fareast-language:EN-GB">From:</span></b><span lang="EN-US" style="mso-fareast-language:EN-GB"> Sami Leino <sami.leino@qnet.fi>
<br>
<b>Sent:</b> 19 August 2021 6:48 am<br>
<b>To:</b> Richard T.A. Neal <richard@richardneal.com>; bind-users@isc.org<br>
<b>Subject:</b> VS: BIND 9.16.19 or any version newer than 9.16.15 does not start on Windows Server 2019<o:p></o:p></span></p>
</div>
</div>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><span lang="EN-US">Hi Richard, and thanks for your reply.</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">This Windows server 2019 runs on VMware and has 8 vCPU ‘s. Although any version newer than 9.16.15 just doesn’t want to start. I just tried the newest release 9.16.20 also, with exactly same problem.</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FI" style="mso-fareast-language:FI">BR, Sami Leino / Q-Net Oy</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FI"> <o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FI"> <o:p></o:p></span></p>
<div>
<div style="border:none;border-top:solid #E1E1E1 1.0pt;padding:3.0pt 0cm 0cm 0cm">
<p class="MsoNormal"><b><span lang="FI" style="mso-fareast-language:FI">Lähettäjä:</span></b><span lang="FI" style="mso-fareast-language:FI"> bind-users <<a href="mailto:bind-users-bounces@lists.isc.org">bind-users-bounces@lists.isc.org</a>>
<b>Puolesta </b>Richard T.A. Neal<br>
<b>Lähetetty:</b> keskiviikko 18. elokuuta 2021 18.38<br>
<b>Vastaanottaja:</b> <a href="mailto:bind-users@isc.org">bind-users@isc.org</a><br>
<b>Aihe:</b> RE: BIND 9.16.19 or any version newer than 9.16.15 does not start on Windows Server 2019</span><span lang="FI"><o:p></o:p></span></p>
</div>
</div>
<p class="MsoNormal"><span lang="FI"> <o:p></o:p></span></p>
<p class="MsoNormal">Hi Sami,<span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"> <span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal">There’s presently an issue where the ISC BIND service (v9.16.19) won’t start on a Windows server with either 8 or 12 vCPUs. How many CPUs (or vCPUs) are in this Windows Server?<span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"> <span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal">I didn’t find that older versions were exhibiting the same issue so it might not be that, but it’s at least a starting point.<span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"> <span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal">Best,<span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"> <span lang="FI"><o:p></o:p></span></p>
<div>
<p class="MsoNormal"><span style="mso-fareast-language:EN-GB">Richard.</span><span lang="FI"><o:p></o:p></span></p>
</div>
<p class="MsoNormal"> <span lang="FI"><o:p></o:p></span></p>
<div>
<div style="border:none;border-top:solid #E1E1E1 1.0pt;padding:3.0pt 0cm 0cm 0cm">
<p class="MsoNormal"><b><span lang="EN-US" style="mso-fareast-language:EN-GB">From:</span></b><span lang="EN-US" style="mso-fareast-language:EN-GB"> bind-users <<a href="mailto:bind-users-bounces@lists.isc.org">bind-users-bounces@lists.isc.org</a>>
<b>On Behalf Of </b>Sami Leino<br>
<b>Sent:</b> 18 August 2021 10:56 am<br>
<b>To:</b> <a href="mailto:bind-users@isc.org">bind-users@isc.org</a><br>
<b>Subject:</b> BIND 9.16.19 or any version newer than 9.16.15 does not start on Windows Server 2019</span><span lang="FI"><o:p></o:p></span></p>
</div>
</div>
<p class="MsoNormal"> <span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Hello,</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Our NS3.qnet.fi which is Windows Server 2019, does not start ISC Bind process with any newer version than 9.16.15
</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">I have tried to update to 9.16.17 , 9.16.18 and the latest 9.16.19, all those versions refuse to start. Nothing reasonable in event viewer. Always same error when trying to start BIND: Windows could not start the ISC
 BIND service on Local Computer. Error 1067: The process terminated unexpectedly.</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Rollback to version 9.16.15 and process starts normally. Named-checkconf does not return anything.</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Any ideas, what could be the problem? </span>
<span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">C:\DNS\bin>dig -v</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">DiG 9.16.19</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">C:\DNS\bin>net start "isc bind</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">The ISC BIND service is starting.</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><b><span lang="EN-US">The ISC BIND service could not be started.</span></b><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">More help is available by typing NET HELPMSG 3523.</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Only this version works:</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">C:\DNS\bin>dig -v</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">DiG 9.16.15</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">C:\DNS\bin>net start "isc bind</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">The ISC BIND service is starting.</span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><b><span lang="EN-US">The ISC BIND service was started successfully.</span></b><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FI"> <o:p></o:p></span></p>
<table class="MsoNormalTable" border="0" cellspacing="0" cellpadding="0" style="margin-left:5.4pt;border-collapse:collapse">
<tbody>
<tr>
<td width="170" valign="top" style="width:127.6pt;border:none;border-bottom:solid #A6A6A6 1.0pt;padding:0cm 5.4pt 0cm 5.4pt">
<p class="MsoNormal" style="line-height:105%"><span style="mso-fareast-language:FI"><br>
Br,</span><o:p></o:p></p>
<p class="MsoNormal" style="line-height:105%"><span style="mso-fareast-language:FI"><br>
</span><span style="font-size:10.0pt;line-height:105%;color:#1F4E79;mso-fareast-language:FI">Sami Leino</span><span style="font-size:10.0pt;line-height:105%;mso-fareast-language:FI"><br>
Järjestelmäasiantuntija<br>
+358 40 823 8680<br>
<a href="mailto:sami.leino@qnet.fi">sami.leino@qnet.fi</a></span><o:p></o:p></p>
<p class="MsoNormal" style="line-height:105%"><span style="font-size:10.0pt;line-height:105%;mso-fareast-language:FI"> </span><o:p></o:p></p>
<p class="MsoNormal" style="line-height:105%"><span style="font-size:10.0pt;line-height:105%;mso-fareast-language:FI"> </span><o:p></o:p></p>
</td>
<td width="117" valign="top" style="width:87.7pt;border:none;border-bottom:solid #A6A6A6 1.0pt;padding:0cm 5.4pt 0cm 5.4pt">
<p class="MsoNormal" style="line-height:105%"><span style="mso-fareast-language:FI"> </span><o:p></o:p></p>
</td>
</tr>
<tr>
<td width="170" valign="top" style="width:127.6pt;border:none;border-bottom:solid #A6A6A6 1.0pt;padding:0cm 5.4pt 0cm 5.4pt">
<p class="MsoNormal" style="line-height:105%"><span style="font-size:10.0pt;line-height:105%;mso-fareast-language:FI"><br>
Q-Net Oy</span><o:p></o:p></p>
<p class="MsoNormal" style="line-height:105%"><span style="font-size:10.0pt;line-height:105%;mso-fareast-language:FI">Yrittäjänkatu 17
</span><o:p></o:p></p>
<p class="MsoNormal" style="line-height:105%"><span style="font-size:10.0pt;line-height:105%;mso-fareast-language:FI">65380 VAASA</span><o:p></o:p></p>
<p class="MsoNormal" style="line-height:105%"><span style="font-size:10.0pt;line-height:105%;mso-fareast-language:FI"><a href="http://www.qnet.fi/">www.qnet.fi</a></span><o:p></o:p></p>
<p class="MsoNormal" style="line-height:105%"><span style="mso-fareast-language:FI"> </span><o:p></o:p></p>
</td>
<td width="117" valign="top" style="width:87.7pt;border:none;border-bottom:solid #A6A6A6 1.0pt;padding:0cm 5.4pt 0cm 5.4pt">
<p class="MsoNormal" style="line-height:105%"><span style="font-size:10.0pt;line-height:105%;mso-fareast-language:FI"> </span><o:p></o:p></p>
<p class="MsoNormal" style="line-height:105%"><span style="font-size:10.0pt;line-height:105%;mso-fareast-language:FI"><img border="0" width="130" height="72" style="width:1.3541in;height:.75in" id="Kuva_x0020_5" src="cid:image001.png@01D794CD.493D4E40"></span><o:p></o:p></p>
</td>
</tr>
<tr>
<td width="170" valign="top" style="width:127.6pt;padding:0cm 5.4pt 0cm 5.4pt">
<p class="MsoNormal" style="line-height:105%"><span style="font-size:10.0pt;line-height:105%;color:white;mso-fareast-language:FI"> </span><o:p></o:p></p>
<p class="MsoNormal" style="line-height:105%"><a href="http://www.facebook.com/QNetOy1994"><span style="color:windowtext;mso-fareast-language:FI;text-decoration:none"><img border="0" width="20" height="20" style="width:.2083in;height:.2083in" id="Kuva_x0020_2" src="cid:image002.png@01D794CD.493D4E40"></span></a><span style="font-size:10.0pt;line-height:105%;color:white;mso-fareast-language:FI">-</span><a href="https://www.linkedin.com/company/q-net-oy"><span style="color:windowtext;mso-fareast-language:FI;text-decoration:none"><img border="0" width="20" height="20" style="width:.2083in;height:.2083in" id="Kuva_x0020_1" src="cid:image003.png@01D794CD.493D4E40"></span></a><o:p></o:p></p>
</td>
<td width="117" valign="top" style="width:87.7pt;padding:0cm 5.4pt 0cm 5.4pt">
<p class="MsoNormal" style="line-height:105%"><span style="font-size:10.0pt;line-height:105%;mso-fareast-language:FI"> </span><o:p></o:p></p>
</td>
</tr>
</tbody>
</table>
<p class="MsoNormal"><span lang="FI" style="mso-fareast-language:FI"> </span><span lang="FI"><o:p></o:p></span></p>
<p class="MsoNormal"><span lang="FI"> <o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"> </span><span lang="FI"><o:p></o:p></span></p>
</div>
</body>
</html>