feedback requested

Rick Robino rrobino at
Thu May 6 09:08:14 UTC 2004

On May 5, 2004, at 8:35 PM, Mark Andrews wrote:

> 	If you have tried the latest rc/beta could you just drop a
> 	note on how it went.  Silence doesn't alway indicate success.
> 	The output of "uname -a" and whether build were successful
> 	or not is what we are after.
> 	Mark

I tested the version 9 candidates on RHL 7.2 i386, SunOS 5.8 sun4u, 
Darwin 7.3.0 ppc, and OpenBSD 3.4 i386.  9.3.0beta3 and 9.3.4rc3 all 
built and ran Ok.  8.4.5rc2 - not valid for darwin, obsd had some 
runtime warnings but worked**, solaris and linux had no problems.  More 

8x Setup:  CDEBUG="-O2"

9x Setup:
Linux (Linux etc-sys9 2.4.20-28.7 #1 Thu Dec 18 11:31:59 EST 2003 i686 
	./configure --prefix=/test --enable-threads --enable-ipv6 
--with-openssl=/usr/local/ssl \
--with-randomdev=/dev/random --with-libbind

OpenBSD (OpenBSD ns1 3.4 CURRY#0 i386)
	./configure --prefix=/test --enable-threads --disable-linux-caps 
--enable-ipv6 --with-openssl \
--with-randomdev=/dev/random --with-libbind

Solaris (SUNWspro cc) (SunOS mage 5.8 Generic_108528-18 sun4u sparc 
	./configure --prefix=/test --enable-threads --disable-linux-caps 
--enable-largefile --enable-ipv6 \
--with-openssl --with-randomdev=/dev/random --with-libbind

Darwin (Darwin spiff.local 7.3.0 Darwin Kernel Version 7.3.0: Fri Mar  
5 14:22:55 PST 2004; root:xnu/xnu-517.3.15.obj~4/RELEASE_PPC  Power 
Macintosh powerpc)
	./configure --prefix=/test --enable-threads --disable-linux-caps 
--enable-ipv6 --with-openssl \
--with-randomdev=/dev/random --with-libbind

- recent versions of OpenSSL libraries, vendor supplied/approved 
- libbind and v6 added for sake of completeness, no observations other 
than a successful whole-kit build
- chroot only tested on obsd and linux, all survived one recursive 
query for an A RR
- test script ran and most checks passed, the ones that didn't appeared 
to rely on some setup that I didn't bother to do
- bin/tests/system/ does not have an explicit case for 
*-unknown-openbsd*, and with Darwin it (at least on my laptop) did not 
get a value for sys from config.guess because it didn't find that file. 
  Darwin may need to be handled like HP-UX there, but if this was just 
me then the case needs to be changed to *-darwin[5-7]* to be current 

** obsd errors (grain of salt, this machine is a bit of a frankenstein)
./bin/named/named:/usr/lib/ ./bin/named/named : WARNING: 
symbol(__p_class_syms) size mismatch, relink your program


Richard T. Robino

More information about the bind-workers mailing list