patches to make bind9 with TKEY/GSS updates easier to configure

tridge at tridge at
Wed Dec 1 06:35:39 UTC 2010

Hi Michael,

 > There is one problem I haven't solved yet. The test triggers a assert
 > in named if I leave in the "-T clienttest" option in I'm
 > guessing this is some kind of memory tracer?
 >    01-Dec-2010 00:05:24.681 mem.c:1074: INSIST((((ctx->debuglist[i]).head == ((void *)0)) ? isc_boolean_true : isc_boolean_false)) failed, back trace

I've been looking at this failure, and it seems to be an existing
bug. When I run the testsuite against a copy of bind 9.7.2-P2 without
my changes it fails in the same way. 

Here is a backtrace of the failure:

(gdb) bt
#0  0x00007ffff56dea75 in *__GI_raise (sig=<value optimised out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00007ffff56e25c0 in *__GI_abort () at abort.c:92
#2  0x0000000000429fd0 in assertion_failed (file=0x7ffff69b99a2 "mem.c", line=1074, type=isc_assertiontype_insist, 
    cond=0x7ffff69b9d48 "(((ctx->debuglist[i]).head == ((void *)0)) ? isc_boolean_true : isc_boolean_false)") at ./main.c:210
#3  0x00007ffff6976940 in isc_assertion_failed (file=0x7ffff69b99a2 "mem.c", line=1074, type=isc_assertiontype_insist, 
    cond=0x7ffff69b9d48 "(((ctx->debuglist[i]).head == ((void *)0)) ? isc_boolean_true : isc_boolean_false)") at assertions.c:57
#4  0x00007ffff6989c69 in destroy (ctx=0xa7d990) at mem.c:1074
#5  0x00007ffff698a4d5 in isc___mem_putanddetach (ctxp=0xa8cc18, ptr=0x0, size=1400, file=0x47daef "client.c", line=535) at mem.c:1202
#6  0x000000000041863b in exit_check (client=0xa8cc10) at client.c:535
#7  0x00000000004188e5 in client_shutdown (task=0x7ffff7f8ece0, event=0x0) at client.c:609
#8  0x00007ffff699d8a8 in dispatch (manager=0x7ffff7f7b020) at task.c:1013
#9  0x00007ffff699db4c in run (uap=0x7ffff7f7b020) at task.c:1158
#10 0x00007ffff5d849ca in start_thread (arg=<value optimised out>) at pthread_create.c:300
#11 0x00007ffff579170d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

As far as I can tell, this means there is some error in the debug
calls that the code is making, probably in the tkey code. What sort of
rules could the debug code be violation to cause this error?

Cheers, Tridge

More information about the bind-workers mailing list