patches to make bind9 with TKEY/GSS updates easier to configure

tridge at tridge at
Wed Dec 1 11:52:26 UTC 2010

Hi Mark,

 > A memory leak.  The test suite runs with full memory debugging turned
 > on and debuglist[i] has a linked list of arrays with <address,file,line>
 > tuples with a pointer to the allocated memory and which file and
 > line it was allocated at.  When memory is freed the tuple is cleared.
 > When the array is empty it unlinked and freed.

ok, thanks for the info! I'd worked out it was a memory leak since my
last email, but I hadn't worked out how to fix it. The file:line info
in the list just pointed at the isc_mem_allocate() in isc___mem_get()
and I hadn't yet worked out how to track that back to a specific

 > That said we have been chasing a leak in this area.  See attached.

thanks for the patch. Unfortunately after I apply it to 9.7.2-P2 I get
an abort at startup. The REQUIRE(VALID_KEY(key)) in dst_key_alg()
fails. Maybe the patch needs some other changes from CVS?

The bind9 CVS server seems to be down at the moment. I'll try again
with current CVS when that comes back up.

Cheers, Tridge

More information about the bind-workers mailing list