Static Allocation Not Working

Glenn Satchell Glenn.Satchell at
Wed Aug 16 02:50:09 UTC 2006

>To: dhcp-users at
>From: Aaron Thompson <athompson at>
>Subject: Static Allocation Not Working
>Date: Tue, 15 Aug 2006 17:48:25 -0400
>Hey All,
>Sort of an easy issue I’m sure but I’m getting annoyed and could use  
>the help. I searched the archives and this must have been covered but  
>I couldn’t find it.
>Working on Static Allocations for a couple of machines on several  
>subnets. I’m running DHCP Server V3.0.1 in a failover setup.
>In the dhcpd.master file on each server here’s the config the isn’t  
>working: (I've tried a couple of slightly different version of this  
>as go)
>  }
>subnet netmask {
>   option subnet-mask;
>   option broadcast-address;
>   option routers;
>         pool {
>         failover peer "dhcp-failover";
>         deny dynamic bootp clients;
>         range;
>   }
>host {
>   fixed-address;
>   hardware ethernet 00:0a:82:d3:49:22;
>host {
>   fixed-address;
>   hardware ethernet 00:34:3f:13:4f:eb;
>   }
>I’ve stopped the service and deleted all the leases for each MAC  
>address and restarted the service but the machines keep on grabbing  
>an address from the pool. I’m not getting any info from the log’s  
>that I can find, Do I need to add an option statement in the  
> file?
>What easy thing I’m I missing?

Couple of things to check. First up, which pool are test1 and test2
getting an address from? Is it 10.4.130.?

If so, then double check that you have the MAC addresses entered

If not, then you have them plugged in into the right part of the
network. dhcpd will only assign the fixed address if it is right for
the subnet where the request came from.

Also on each client try releasing the current lease, eg for windows use

  ipconfig /release

For logging, you need to edit /etc/syslog.conf and change the level to
debug for your dhcpd messages. The defaults in syslog.conf vary between
different versions of Unix/Linux so I don't know what you might
currently have. Afer changing syslog.conf you need to restart the
syslog daemon.

Here's what I have in /etc/syslog.conf (note the white space *must* be

local7.debug                /var/log/dhcp/dhcpd.log

and in dhcpd.conf:

log-facility local7;

Once you get the logging sorted out you should see requests like this:

Aug 11 09:46:52 drill dhcpd: [ID 702911] DHCPDISCOVER from 00:90:27:19:22:c2 via 
Aug 11 09:46:52 drill dhcpd: [ID 702911] DHCPOFFER on to 
00:90:27:19:22:c2 via hme0
Aug 11 09:46:52 drill dhcpd: [ID 702911] DHCPREQUEST for 
( from 00:90:27:19:22:c2 via hme0
Aug 11 09:46:52 drill dhcpd: [ID 702911] DHCPACK on to 
00:90:27:19:22:c2 via hme0

This is the typical request from a client starting from scratch.

If still no luck, but you get logging to work better for you then post
the log messages.

Glenn Satchell       mailto:glenn.satchell at  |  Heard about
Uniq Advances Pty Ltd   |  the new Unix
PO Box 70 Paddington NSW Australia 2021                 |  sports car?
tel:0409-458-580   tel:02-9380-6360   fax:02-9380-6416  |  The  rwx

More information about the dhcp-users mailing list