silently neglected requests fixed by restarting dhcpd

Gordon A. Lang glang at
Tue May 9 14:16:42 UTC 2006

I'm looking for some help.
We started using dhcpd 3.0.3 on March 28, 2006 for 15 out of our 45 VLAN's and it worked fine for a few weeks.  The other 30 VLAN's continued to be serviced by our Microsoft DHCP server.

Then we added the rest of our VLAN's, and it worked fine for a while until the morning rush at which time there were too many problems to figure out so we backed out our change for most of the VLAN's.  This didn't help though because the problems were occurring on the VLAN's that had previously been working.  Shutting down the failover partner, and restarting the primary server finally fixed the problem.

Everything seemed fine for the last couple of weeks with the dhcpd server handling about 25 VLAN's.

Today I tried once again to migrated the remaining VLAN's.  Again, everything seemed fine initially, but then problems began to occur.

Renewals would work, but initial requests (forwarded by the routers via helper-address) were failing on some VLAN's.  The interesting thing is that most of the failures were occurring on the original VLAN's that have been working since March 28.

The problems this time were different than last time in some important ways, but the problems persisted until I did a stop and restart of the dhcpd daemon.  Since then everything seems fine again.

We have two routers using HSRP and all VLAN's have helper-address configuraitons.

Any ideas?

Gordon A. Lang

More information about the dhcp-users mailing list