no log generation

Kevin Dierking Kevin.Dierking at
Tue Oct 31 18:32:21 UTC 2006

By default the syslog server on BSD 5.x and later defaults to secure mode 
syslogd_flags="" to your /etc/rc.conf to override the default setting and 
try a restart of syslog.
For testing purposes in our lab we use syslogd_flags="-a*:*"

This may be part of the solution.

Roberto Greiner <mrgreiner at> 
Sent by: dhcp-users-bounce at
10/31/2006 11:48 AM
Please respond to
dhcp-users at

dhcp-users at

no log generation


I've installed isc-dhcpd recently, but did something wrong. The server is 
working properly, assigning IP addresses to clients, but for some reason 
no log is being generated at all. The only reason I'm sure the server is 
working properly is because tshark did show that the packets are getting 
in and out as expected. The only messages that the deamon
generated at all in /var/log/messages where the following:

dhcpd: Abandoning IP address pinged before offer

To see if it was some problem with firewall blocking the messages to the 
syslog deamon, I tried disabling the firewall completely with 'pfctl -d', 
but still didn't get any log.

I also tried running the server on foreground, and the logs were generated 
on the screen without any problem. The command I used was:
/usr/local/sbin/dhcpd -f -d -cf /usr/local/etc/dhcpd.conf -lf 
/var/db/dhcpd/dhcpd.leases -pf /var/run/dhcpd/ -user dhcpd -group 
dhcpd bge1

I just added '-f -d' to what I saw as being started by the start-up 

Can somebody help me find out what's wrong?

Here is the data about my install:
OS: FreeBSD 6.1
ISC-DHCPd version 3.0.3
The machine has two ethernet boards. One with a valid IP address (bge0),
the other inside the NATed network (bge1), where it is assigning the

config file:
option domain-name "domain.xxxx.xxxx";
default-lease-time 7200;
max-lease-time 86400;
log-facility local7;
ddns-update-style none;
subnet netmask {
        option routers;
        option domain-name-servers;
        default-lease-time 7200;
        max-lease-time 86400;

In the syslog file I added the following line:
local7.*                                        /var/log/dhcpd.log

Syslog was properly restarted after that, but no data at all is beeing
entered on the above file. I tried creating the file with touch, but
without results.

In rc.conf I addesd the following lines:

The bge1 interface, has the following configuration in rc.conf:
ifconfig_bge1="inet  netmask"
ifconfig_bge1_alias0="inet  netmask"

Thank you for your help,

Marcos Roberto Greiner

|                     Marcos Roberto Greiner                        | 
|                                                                   | 
|         Os otimistas acham que estamos no melhor dos mundos       | 
|         Os pessimistas tem medo de que isto seja verdade          | 
|                                                     Murphy        | 
|                         rgreiner at                           | 

"This communication is for use by the intended recipient(s) only and may 
contain information that is privileged, confidential and exempt from 
disclosure or unauthorized use under applicable law. If you are not an 
intended recipient of this communication, you are hereby notified that any 
dissemination, distribution, copying or use of this document or 
information contained in this document is strictly prohibited. If you have 
received this communication in error, please notify me by reply e-mail or 
fax, permanently delete this communication from your system, and destroy 
any hardcopies you may have printed. *This communication is covered by the 
Electronic Communications Privacy Act, 18 U.S.C. 2510-2521."

More information about the dhcp-users mailing list