dhcpv6: Segmentation fault on Request

Chinmaya Reddy chinmayareddy at gmail.com
Wed Aug 15 21:33:34 UTC 2007


This bug seems to partially exist, I tried alpha2 version,
it works fine if the server receives Solicit directly from the client,
however I still get segmentation fault when server receives relay-forward.
Any clue how to get it working?

---- my configuration file ----
ddns-update-style none;
ddns-updates off;
do-forward-updates off;

#Subnet of DHCP Server
subnet6 fe80::/64 {
    range6 fc00:0000:4491:0200::/64;
    option dhcp6.name-servers fc00::10:zzzz:zzzz:zzzz;
---- my configuration file ----

--- server output ---
Wrote 0 leases to leases file.
Listening on Socket/eth0/fe80::/64
Sending on   Socket/eth0/fe80::/64
Relay-forward message from fe80::XXXX:XXXX:XXXX:7777 port 547, link
address ::, peer address fe80::XXX:XXXX:XXXX:6666
./dhcpstart.sh: line 6: 26643 Segmentation fault      dhcpd -6 -f -d
-cf ./dhcpv6.conf -lf ./dhcpv6.leases eth0
--- server output ---

---- relay-forward message ----
Frame 3989 (160 bytes on wire, 160 bytes captured)
    Arrival Time: Aug 15, 2007 14:32:55.279209000
    [Time delta from previous packet: 0.000866000 seconds]
    [Time since reference or first frame: 57.684515000 seconds]
    Frame Number: 3989
    Packet Length: 160 bytes
    Capture Length: 160 bytes
    [Frame is marked: False]
    [Protocols in frame: sll:ipv6:udp:dhcpv6]
    [Coloring Rule Name: UDP]
    [Coloring Rule String: udp]
Linux cooked capture
    Packet type: Sent by us (4)
    Link-layer address type: 1
    Link-layer address length: 6
    Source: MyComp_YY:YY:YY (YY:YY:YY:YY:YY:YY)
    Protocol: IPv6 (0x86dd)
Internet Protocol Version 6
    Version: 6
    Traffic class: 0x00
    Flowlabel: 0x00000
    Payload length: 104
    Next header: UDP (0x11)
    Hop limit: 64
    Source address: fe80::XXX:XXXX:XXXX:7777 (fe80::XXXX:XXXX:XXXX:7777)
    Destination address: ff05::1:3 (ff05::1:3)
User Datagram Protocol, Src Port: dhcpv6-server (547), Dst Port:
dhcpv6-server (547)
    Source port: dhcpv6-server (547)
    Destination port: dhcpv6-server (547)
    Length: 104
    Checksum: 0xe219 [correct]
    Message type: Relay-forw (12)
    Hop count: 0
    Link-address: ::
    Peer-address: fe80::XXXX:XXXX:XXXX:6666
        option type: 18
        option length: 4
    Relay Message
        option type: 9
        option length: 50
            Message type: Solicit (1)
            Transaction-ID: 0x004f59d8
            Client Identifier
                option type: 1
                option length: 14
                DUID type: link-layer address plus time (1)
                Hardware type: Ethernet (1)
                Time: 1187136401
                Link-layer address: mm:mm:mm:mm:mm:mm
            Identity Association for Non-temporary Address
                option type: 3
                option length: 12
                IAID: 1
                T1: infinity
                T2: infinity
            Elapsed time
                option type: 8
                option length: 2
                elapsed-time: 100 sec
            Option Request
                option type: 6
                option length: 2
                Requested Option code: DNS recursive name server (23)
---- relay-forward message ----


>> Hi,
>> i have the same problem.
>> This is my configuration file :
>> authoritative;
>> ddns-updates off;
>> ddns-update-style interim;

> I see the bug.

> In the meantime, please use;

> 	ddns-update-style none;

> (removing ddns-updates from config, but still doing no updates)

> We'll fix this in a2.

> --
> Ash bugud-gul durbatuluk agh burzum-ishi krimpatul.
> Why settle for the lesser evil?	 https://secure.isc.org/store/t-shirt/
> --
> David W. Hankins	"If you don't do it right the first time,
> Software Engineer		     you'll just have to do it again."
> Internet Systems Consortium, Inc.		-- Jack T. Hankins

More information about the dhcp-users mailing list