Problem with "corrupt" lease file

Mike Schmidt mike at
Mon Jul 2 16:01:08 UTC 2007

I was finally able to replace the older version of dhcpd with the most
recent version I could find (recompiled from the the redhat rpms for
EL5). The problem is solved now,
as I was hoping. The uptodate dhcp writes the earlier option
(agent.#43)  as agent.unknown-43.  It, of course, won't read the
offending values in the leases file. However, this is a rather odd way
of escaping the  option name.

However, as Niall says, the problem is not entirely solved, though.
After reading every man page carefully, I found no documentation, even
in 3.0.5, that describes how invalid characters in option names can be
escaped (there's not even a clear description of what characters are
allowed in option names. I think that at least somewhere in one of the
man pages it would be nice to have a clear definition of option name
syntax . I could have in that case  converted the leases file, even done
it  on a regular basis where I might not be able to upgrade.

The problem is that often, on production systems, it can be very
difficult to change a component as critical as dhcpd, so having a clear
definition can provide a way around the problem.

Thanks very much, I have learned a lot about dhcp in the last few days,
and most of it is due to the dhcp-user list. Thanks again.


Niall O'Reilly wrote:
> On 1 Jul 2007, at 18:25, Simon Hobson wrote:
>> So your argument is "it looks like a bug, upgrade and see if the
>> problem is fixed" ?
> 	Now that you put it like that, yes!  8-)
> 	It's occurred to me since that one way of "rectifying" the existing
> 	leases file so that 3.0.5 can read it just after the upgrade would
> 	simply be to remove the offending option line from any "damaged"
> 	lease.  As an "escaping convention" this is a little extreme.  8-)
> 	ATB
> 	/Niall

More information about the dhcp-users mailing list