DHCP Multiple VLAN problem

john s e_z_now_peeps at hotmail.com
Fri Jul 20 06:25:32 UTC 2007

Hi,Thanks for your reply, it looks like it would do, I will try later, but the phone needs a valid gateway (or none) the first time it comes up in VLAN1, if it doesn't then it just hangs and arps for it, if I make it go straight to the final subnet I want it on then it ends up in a subnet with a valid address, but where it is on VLAN1 but everything else is on VLAN10 (including the gateway) so it just hangs. This is the problem, getting it to go one one subnet the first time, another one the second and controlling device access to these pools.Thanks for your help> Subject: Re: DHCP Multiple VLAN problem> From: allie at lsu.edu> To: dhcp-users at isc.org> Date: Thu, 19 Jul 2007 17:40:51 -0500> > This is what I have for my avaya setup here.  Would this work for you?> > class "avaya-phones" {>         match if (substring (hardware, 1, 3) = 00:04:0d);>         option op176...> 	....> 	....> }> > > #DSCRP:Various> shared-network Various {>         subnet netmask {>                 ignore client-updates;>                 option routers;>                 option broadcast-address;>                 # known clients get this pool.>                 pool {> 			.> 			.> 			.> 			allow known-clients;> 			allow members of "avaya-phones";>                         deny dynamic bootp clients;>                         deny members of "ras-servers";>                         deny members of "deny";>                 }>          }>          subnet netmask {>                 ddns-updates off;>                  option routers;>                  #unknown clients get this pool.>                  pool {> 			.> 			.> 			.>                          allow unknown clients;>                          deny members of "ras-servers";>                          deny members of "avaya-phones";>                          allow members of "RIS-Clients";>                  }>          }> }> > > On Thu, 2007-07-19 at 22:10 +0000, Scott F wrote:> > > > Hi,> > > > I am having a bit of a problem trying to get some IP Phones (Mitel) working with ISC DHCP 3> > > > Basically we have 2 subnets set up in a shared network. One is for the> > VLAN1 data traffic and the other is for the VLAN 10 voice traffic. The> > DHCP Server is in VLAN1 and there is an IP Helpr set up to forward the> > DHCP traffic from VLAN1 to 10 (on the 3com 5500). On the VLAN 1 subnet> > all the computers are statically assigned addresses by MAC. I have set> > up two pools of addresses, one of VLAN1 range and the other on VLAN 10> > range. When the phones start up they are on VLAN1 and broadcast for an> > address, they get one along with other options that tell it that it> > should be on VLAN10, the phone releases its address and comes up on> > VLAN10 where it broadcasts and gets an address in the VLAN10 range,> > because the request comes from the helper, all seems to work ok.> > However, work want to have the pools set so people can't just plug in> > any device and get an address, but whenever I put any sort of> > conditional statement in DHCPd sees this as the most specific option> > and goes to the subnet containing it ignorning whether it has come by> > the helper or not. I even tried setting up the 3com switch to add> > option 82 info to the DHCP packet so I could ID which VLAN the request> > was from, this worked fine except the switch only tagged the first> > packet from VLAN10 (the DHCPDISCOVER), the next one ( DHCPREQUEST)> > wasn't tagged so the server sees it as being in VLAN1. > > > > Any ideas anyone? this is driving me up the wall> > _________________________________________________________________> > The next generation of MSN Hotmail has arrived - Windows Live Hotmail> > http://www.newhotmail.co.uk> > > 
Celeb spotting – Play CelebMashup and win cool prizes

More information about the dhcp-users mailing list