Cisco ASA 5520 and DHCP relay

Eimantas Zdanevičius eimantas at
Wed Mar 12 15:00:41 UTC 2008

Hello all,

I have linux dhcp server connected to one ASA 5520 (routing mode, single
context) interface, and dhcp clients connected to other ASA 5520
interface. I have set dhcprelay agent on asa:

dhcprelay server dhcp_server servers
dhcprelay enable test
dhcprelay timeout 60

Linux DHCP server configuration:

default-lease-time  1800;    # 1/2 hour
max-lease-time      3600;    # 1 hour
min-lease-time       900;    # 1/4 hour
one-lease-per-client true;
option arp-cache-timeout 3600;
option netbios-node-type 1;
ddns-update-style none;
ddns-updates off;
subnet netmask {
        option routers        ;
        option subnet-mask    ;
        option domain-name-servers,;
        host asus { fixed-address; hardware ethernet
00:18:f3:3e:bc:3e; }

I have laptop (named asus in dhcp config) with Windows XP and Linux
operating systems. When i run Windows XP my laptop gets ip address and
all works fine. But linux cant get ip address from dhcp server.

i can't see any activity on dhcp server from linux client (message.log,
tcpdump), when i run windows i see DHCP messages on dhcp server.

how can i resolve this problem?

How can i debug dhcp packets on asa5520?


More information about the dhcp-users mailing list