DDNS, ISC-DHCPD, and Bind... not working because of strange error messages

Da Rock rock_on_the_web at comcen.com.au
Sat Mar 29 01:07:41 UTC 2008

I did actually manage to get this to work, and I can't exactly work out
what changed to cause this error.

I'm running FreeBSD 6.3, and sent this to the net and questions list
there, but no one seems to know what is going on because I have received
no response at all (posted around a week ago). So I thought I should go
to the top - and ask the pros.

I set this up at the end of last year, and it worked- kind of. The
failure was my own by not using a proper FQDN, but it worked
unofficially anyway. Records were updating etc: all happy.

Anyway, I finally got the FQDN worked out (split horizon dns- external
and internal views), but I find that the ddns is not working: and not
because of the changes I made. I looked back and found the problem going
on for month. My messages file has these entries, and no amount of
googling has brought me any closer to finding out what they could mean,
or why my clients aren't updating:

Mar 27 16:18:54 {$HOSTNAME} dhcpd: pool.ntp.org: no A record associated
with address

I've edited the hostname to protect the innocent.

What I can't figure out is why would dhcpd be looking at pool.ntp.org? I
ran a dig on pool.ntp.org on the off chance it was busted- but of course
it was not. And this record pops up everytime I renew my ip addresses.

Little help anyone?


More information about the dhcp-users mailing list