DDNS, ISC-DHCPD, and Bind... not working because of strange error messages

Da Rock rock_on_the_web at comcen.com.au
Sat Mar 29 22:53:37 UTC 2008

We can top post here?

Thank you! Finally a response... :)
In order of questioning:
No- the pool.ntp.org is what truely confuses me.
Yes- dig ran fine, got an authoritative answer.
Yes- I can get everything. I have an IP address and I can also resolve
all entries in my zone files on bind. I just can't update entries it

I can understand your point. I'm trying to do the same. Based on these
answers does this mean it dhcpd or bind? I suspect its dhcpd myself.

server-identifier $serverip
ddns-update-style interim;
ddns-ttl 14400;

key $domain.key {
        algorithm hmac-md5;
        secret "$secret";

zone $domain {
        primary $serverip;
        key $domain.key;

zone $rev-domain {
        primary $serverip;

subnet $private-net netmask {
        range $private-net-range $private-net-range;
        option subnet-mask;
        option broadcast-address $private-net-bcast;
        option domain-name "$domain";
        one-lease-per-client on;
        default-lease-time 14400;
        max-lease-time 14401;
        option ip-forwarding off;
        option time-offset -18000;
        option routers $gateway;
 	option domain-name-servers $serverip;

I have a question too. I set this up based on very basic info found
through a google search. Should the hostname be set by the client and
updated in the dns by dhcpd? Or should (can I) setup the hostname from
the dns by dhcpd on the client? What is the correct way to do this?


On Sun, 2008-03-30 at 00:19 +1100, Glenn Satchell wrote:
> You'll need to post your dhcpd.conf. The list software strips
> attachments, so include it in the body of the email.
> A couple of general questions:
> Is pool.ntp.org mentioned anywhere in your dhcpd.conf?
> Can you resolve that name using, say, dig or nslookup?
> Can you resolve other internet IP addresses (eg www.isc.org,
> www.google.com, etc)?
> Just trying to work out if it's a general dns resolution issue, or
> something specific about dhcpd.
> regards,
> -glenn
> >Subject: DDNS, ISC-DHCPD, and Bind... not working because of strange error 
> messages
> >From: Da Rock <rock_on_the_web at comcen.com.au>
> >To: dhcp-users at isc.org
> >Date: Sat, 29 Mar 2008 11:07:41 +1000
> >
> >I did actually manage to get this to work, and I can't exactly work out
> >what changed to cause this error.
> >
> >I'm running FreeBSD 6.3, and sent this to the net and questions list
> >there, but no one seems to know what is going on because I have received
> >no response at all (posted around a week ago). So I thought I should go
> >to the top - and ask the pros.
> >
> >I set this up at the end of last year, and it worked- kind of. The
> >failure was my own by not using a proper FQDN, but it worked
> >unofficially anyway. Records were updating etc: all happy.
> >
> >Anyway, I finally got the FQDN worked out (split horizon dns- external
> >and internal views), but I find that the ddns is not working: and not
> >because of the changes I made. I looked back and found the problem going
> >on for month. My messages file has these entries, and no amount of
> >googling has brought me any closer to finding out what they could mean,
> >or why my clients aren't updating:
> >
> >Mar 27 16:18:54 {$HOSTNAME} dhcpd: pool.ntp.org: no A record associated
> >with address
> >
> >I've edited the hostname to protect the innocent.
> >
> >What I can't figure out is why would dhcpd be looking at pool.ntp.org? I
> >ran a dig on pool.ntp.org on the off chance it was busted- but of course
> >it was not. And this record pops up everytime I renew my ip addresses.
> >Weird...
> >
> >Little help anyone?
> >
> >Cheers
> >
> >
> >

More information about the dhcp-users mailing list